Submit a ticketCall us

WebinarWebinar: A checklist for planning your Network Performance Monitor (NPM) upgrade

Are you ready for your next upgrade? To help you plan smoothly, join this webcast to learn more about, SolarWinds® Orion® Installer, SolarWinds Upgrade Advisor, Upgrades Guides, Training Videos, and other resources available. We’ll share key upgrade planning considerations, lessons learned from customers with practical advice from SolarWinds Product Experts. We’ll also give practical tips to identify the estimated time needed and resources, how to prepare the business and IT staff for changes, ways to plan for required system changes, and more.

Register now.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Unable to connect to a target machine through WMI

Unable to connect to a target machine through WMI

Created by Riggs Clough, last modified by Karen Valdellon_ret on Jul 04, 2016

Views: 984 Votes: 1 Revisions: 2

Updated July 4, 2016

Overview

This article addresses the issue where you are unable to connect to a node through WMI and get an error when testing through WBEMTEST.

Environment

All Orion Core versions

Cause 

This occurs when the WMI repository is inconsistent.

Resolution

  1. Open an elevated command prompt on the target machine that you want to monitor.
  2. Verify that the WMI repository is not corrupt by running the following command:
    winmgmt /verifyrepository
  3. If the command results in an inconsistent repository, perform the following
    1. Shut down Windows Management Instrumentation.
    2. Run the following command to rebuild the WMI repository
      winmgmt /salvagerepository
    3. Restart the WMI related services.
    4. Check if you are now able to connect to the target node in Orion.
       

 

Last modified

Tags

Classifications

Public