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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Unable to Remove the ShadowCopyCache directory in NPM

Unable to Remove the ShadowCopyCache directory in NPM

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Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 946 Votes: 0 Revisions: 12

Unable to remove the ShadowCopyCache directory in the JobEngine folder.
Errors related to Access Denied are showing in the SolarWinds.JobEngineService_v2 logs even after Antivirus program scanning exclusions were made as per What files and directories should I exclude from antivirus protection to optimize performance and to ensure adequate file access for Orion products?
Below are several examples of the error message:

2014-09-10 15:05:48,989 [33] WARN SolarWinds.JobEngine.Engine.WorkerProcessWCFProxyFactory - Can't remove directory C:\Windows\TEMP\SolarWinds\JobEngine.v2\ShadowCopyCache-12200 System.UnauthorizedAccessException: Access to the path 'SolarWinds.APM.BlackBox.Sql.Strings.DLL' is denied.

2014-09-10 15:10:07,054 [17] WARN SolarWinds.JobEngine.Engine.WorkerProcessWCFProxyFactory - Can't remove directory C:\Windows\TEMP\SolarWinds\JobEngine.v2\ShadowCopyCache-856
System.UnauthorizedAccessException: Access to the path 'pspluginwkr.dll' is denied.

2014-09-10 15:22:23,923 [5] WARN SolarWinds.JobEngine.Engine.WorkerProcessWCFProxy - Could not delete C:\Windows\TEMP\SolarWinds\JobEngine.v2\ShadowCopyCache-24176
System.UnauthorizedAccessException: Access to the path 'SolarWinds.Logging.DLL' is denied.

Cause:

The JobEngine failed to create a new cache copy in the same directory.

Resolution:

1. Stop all Orion services - How to Start/Stop Orion Services.
2. Clear the Jet files (jet*.tmp in c:\Windows\Temp).
3. Restart the services - How to Start/Stop Orion Services.
4. Check and confirm that a new cache copy was created.
5. Check and confirm that there are no longer errors in the JobEngine log.

Applies to: NPM v11.0.

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