Submit a ticketCall us

Training ClassSign up for Network Performance Monitor (NPM) and Scalability instructor-led classes

Attend our instructor-led classes, provided by SolarWinds® Academy, to discuss the more advanced monitoring mechanisms available in NPM as well as how to tune your equipment to optimize its polling capabilities. NPM classes offered:
NPM Custom Monitoring and Polling
Orion Platform Scalability

Reserve your seat.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Solarwinds Job Engine v2 and Job Scheduler stops intermittently or completely

Solarwinds Job Engine v2 and Job Scheduler stops intermittently or completely

Created by James Fahey, last modified by Aileen de Lara_ret on Jul 15, 2016

Views: 4,241 Votes: 7 Revisions: 3

Updated July 15, 2016

Overview

This article provides brief information and steps to resolve the issue when the Job Engine v2 and Job Scheduler stops or starts intermittently. The following error is displayed:

Fatal SolarWinds.JobEngine.ServiceProces.SolarWindsService - OnStart: Unhandled Execpetion caught
System.IO.FileNotFoundExecption: Could not load file or assembly 'System.Data.SQLServerCE, Version=3.5.1.0,
Cutlure=neutral, PublickKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
File name: 'System.Data.SQLServerCE, Version=3.5.1.0, Cutlure=neutral, PublickKeyToken=89845dcd8080cc91'
     at SolarWinds.JobEngine.Data.SqlCeHelper.Verify()
     at SolarWinds.JobEngineService.v2.JobEngineServiceApp.VerifyDatabaseConsistencyAndVersion()
     at Solarwinds.JobEngineService.v2.JobEngineServiceApp.Start(ServiceOperationMode operationMode, CommunicationSettings
settings)
     at SolarWinds.JobEngineService.v2.JobeEngineServiceApp.Start()
     at Solarwinds.JobEngine.ServiceProcess.SolarWindsService.ServiceStart()

Environment

All Orion Core platforms

 

Cause 

The Microsoft SQL Server Compact 3.5 ENU (x86 and x64) were either not installed or uninstalled.

These can be viewed in the Control Panel of the Orion App Server.

 

Resolution

1. Log on the Orion App Server and stop all Orion services in Orion Service Manager.

2.  Go to the following directory:

C:\ProgramData\Solarwinds\Installers

3. Right-click and uninstall the following:

  • CollectorInstaller.msi
  • JobEngine.msi
  • JobEngine.v2.msi

4. Right-click on the following and select Install:

  • SSCERuntime_x86-ENU.msi
  • SSCERuntime_x64-ENU.msi

5. Right-click on the following and select Install:

  • CollectorInstaller.msi
  • JobEngine.msi
  • JobEngine.v2.msi

6. Start all the Orion services in Orion Service Manager.

 

 

 

Last modified

Tags

Classifications

Public