Submit a ticketCall us

AnnouncementsChange Is Inevitable

Get valuable help when it comes to tracking and monitoring changes. SolarWinds® Server Configuration Monitor (SCM) is designed to help you: detect, track, and receive alerts when changes occur, correlate system performance against configuration changes, compare server and application configuration against custom baselines, and verify application and system changes.

Learn more.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > ​SolarWinds.Core.Heatmaps.BusinessLayer -  Service was unable to open new database connection when requested

​SolarWinds.Core.Heatmaps.BusinessLayer -  Service was unable to open new database connection when requested

Created by Kevin Twomey, last modified by MindTouch on Jun 23, 2016

Views: 1,224 Votes: 0 Revisions: 6

Overview

The SolarWinds Orion Core Business Layer keeps crashing with the following out of memory error message. 


SolarWinds.Core.Heatmaps.BusinessLayer - 
Service was unable to open new database connection when requested.

OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.

 

The following error message is seen in SolarwindsDiagnostics\LogFiles\Orion\Core.BusinessLayer.log.  
2016-02-08 20:32:18,845 [116] ERROR SolarWinds.InformationService.Contract2.InfoServiceProxy - An error occured opening a connection to the orion communication service.

System.TimeoutException: The open operation did not complete within the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException: The socket transfer timed out after 00:01:00. You have exceeded the timeout set on your binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Environment

  • NPM 11.5.2  
  • SAM 6.2.2 
  • DPA 10  
  • NTA 4.1.0
  • Windows Server 2012 R2
  • SQL Server 2008 SP3

Cause 

This may be due to any of the following:

  • Obsolete InformationServiceProxyCreator class used in alerting in Business Layer in the Orion 2015.1.2 branch (e.g. SolarWinds.Orion.Core.BusinessLayer.DAL.AlertDAL.cs) may leak TCP/IP connections used in Orion.
  • The limit of available TCP/IP connections is reached and the module crashes.
  • Memory leak on .NET objects related to WCF.

Resolution

​Install HotFix 1 or upgrade NPM to 11.5.3, which includes all previous HotFixes. Go to the SolarWinds Customer Portal site to download the HotFix and latest version of NPM.

Last modified

Tags

Classifications

Public