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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Schema Error after Upgrade

Schema Error after Upgrade

Created by Eric Bryant, last modified by MindTouch on Jun 23, 2016

Views: 853 Votes: 0 Revisions: 4

Overview

This article provides information on general Schema errors in the Configuration Wizard resolution steps.

 

Errors in the Information service logs:

2013-01-10 15:09:04,379 [19] ERROR SolarWinds.InformationService.Core.InformationService - Exception caught in method RunQuery
SolarWinds.Data.Query.EntityNotFoundException: Source entity [Orion.NPM.Schema] not found in catalog

 

Environment

NPM version 9.5 and later

 

Cause 

Schema conflicts in SWIS after an upgrade (usually with older versions of Core).

 

Resolution

1. Locate the ConfigurationWizard.exe.config and open it in a text editor. 
2. Locate the XML element <appSettings>.
3. Add <add key="Packaging.Internal.RepairMode" value="true"/> element into <appSettings> and then save file.
4. Stop all SolarWinds services and websites.
5. Run SolarWinds Configuration Wizard and select all three options here.
6. Set the key to false after Configuration Wizard has completed.

 

 

 

 

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