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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Scheduled Reports issue after upgrade to NPM 12

Scheduled Reports issue after upgrade to NPM 12

Updated August 22, 2016

Overview

After upgrading to NPM 12, scheduled reports in emails have a black background. The emails look similar to the screenshot below:

 

Environment

Orion Platform 2016.1 and later

 

Cause 

&PRINTABLE=TRUE is added in the Report URL which causes the HTML page to appear with all Forms & Menus.

Resolution

  1. Create a backup of your Orion database.
  2. Log in to the Orion Server.
  3. Stop All Orion Services using Orion Service Manager.
  4. Open Database Manager & Expand the Orion Database.
  5. Right-click the Orion Database and select New Query.
  6. Copy and Paste the following query:
      UPDATE [dbo].[ActionsProperties]
        SET [PropertyValue] = 'True'
        WHERE [PropertyName] = 'Printable' AND [ActionID] IN
        (SELECT DISTINCT ap.[ActionID] FROM [dbo].[ActionsProperties] ap
        INNER JOIN [dbo].[ActionsAssignments] aa ON aa.ActionID = ap.ActionID
        WHERE aa.[EnvironmentType] = 'Reporting' AND ap.[PropertyName] = 'ContentTypes' AND ap.[PropertyValue] LIKE '%HTML%')
  7. Restart all Orion Services.

  8. Re-run the effected Schedule and confirm that the Report is now executing correctly.

 

 

 

 

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