Submit a ticketCall us

AnnouncementsFace your biggest database issues head-on

Our new eCourse helps you navigate SQL Server performance blocks by teaching you how to recognize and deal with the three DBA Disruptors: Performance Hog, Blame Shifter, and Query Blocker. Register today to learn how to defend your environment and fend off menacing disruptions.

Register for your free eCourse.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > SNMPv3 issue with NPM 11.5.2 - Error 31224 Crypto Error - Unable to perform the requested algorithm

SNMPv3 issue with NPM 11.5.2 - Error 31224 Crypto Error - Unable to perform the requested algorithm

Created by Kevin Twomey, last modified by MindTouch on Jun 23, 2016

Views: 1,798 Votes: 3 Revisions: 4

Overview

SNMPv3 Nodes displaying the following error message on some Orion Polling Engines while attempting to run a SNMP walk on the SNMPv3 device:

 

Error 31224 Crypto Error - Unable to perform the requested algorithm.

If FIPS restristions are enabled, please select a FIPS compliant algorithm.


Also, ​Alerting Action fails for some of the trigger actions 
Execute program : "D:\Program Files (x86)\SolarWinds\Orion\APM\SolarWinds.APM.RealTimeProcessPoller.exe

Environment

  • NPM 11.5.2
  • SAM 6.2.2
  • NTA 3.11
  • IPAM 4.3.0  
  • WPM 2.2
  • 9 Orion Polling Engines
  • Microsoft Windows Server 2008 R2 Enterprise
  • 274 Hotfix(s) Installed

Cause 

The working Additional Polling Engine has:                                                                                                                                            

  • C:\Program Files (x86)\Common Files\SolarWinds\OpenSSL\x64\libeay32.dll = Version 1.0.2.1

The working Additional Polling Engine has:                                                                                                                                            

  • C:\Program Files (x86)\Common Files\SolarWinds\OpenSSL\x64\libeay32.dll = Version 1.0.2.4
     

Resolution

Warning: Consult your System Administrator before performing the following procedure. 

 

  1. Stop the Orion Services on Non Working Poller using the Orion Service Manager.

  2. Back up the Open SSL folder located at C:\Program Files (x86)\Common Files\SolarWinds\OpenSSL.
  3. Delete both the x86 and 64 folders.
  4. Copy the same folder from the working poller to the non working poller in same location, both the x86 and 64 folders.
  5. Restart all Orion Services using the Orion Service Manager.
Last modified

Tags

Classifications

Public
/*]]>*/