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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Notepager Pro is unable to send SMS

Notepager Pro is unable to send SMS

Updated: August 10, 2016

Overview

This article describes the issue when you see alerts triggering in Orion and sent to Notepager Pro but some messages are left in Pending or Bad State and not being delivered. 

 

 

Environment

  • All Versions of NPM 
  • All Versions of SAM
  • Netpager Pro 3.0+

 

Cause 

  • The message you are sending is too long, or has illegal characters in it. 
  • Alert Messages can contain variables which do not translate over (Old Alerting Variables which should have been upgraded) can be included in the body of message text and cause NotepagerPro to classify the message as bad
     
  • Example of Variables which caused this scenario:
    {$IpAddress} 
    Volume ${FullName}:
    Total size ${VolumeSize}
    Free space ${VolumeSpaceAvailable}
    Percent used ${VolumePercentUsedwhich causes NotepagerPro to class the messages as bad.

 

 

Resolution

1. Edit the Message of the Alerts on which are classed as Bad by Notepager & test using the send an email action to make sure all variables within the message text are being translated.

2. Reduce the Size of the message text and test again.

3. You can Edit the Alert Message sent by Orion b:

a. Log in the Web Console.

b. Click Settings.

c. Manage Alerts.

d. Edit the Alert.

c. Edit the Trigger and Reset Actions.

 

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