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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Network Atlas maps load slowly or do not load

Network Atlas maps load slowly or do not load

Updated July 3, 2018

Overview

After upgrading SolarWinds products that include Network Atlas (for example, NPM), maps may either load slowly or not load in the Orion Web Console. You may also notice that the Network atlas app cannot load maps on remote clients.

By default, Network Atlas loads every entity that can be displayed on the map, including entity dependencies, properties, and status calculations. In large environments with many entities, map data may load slowly or the system will timeout due to the amount of data involved.

Environment

If you encounter issues with Network Atlas maps loading slowly or not loading after upgrading Orion Platform 2017.3 or 2018.2 products (for example, NPM 12.2 or NPM 12.3), see Network Atlas Maps load slowly or do not load in NPM 12.2 and later.

This issue may occur after upgrading to products that include Network Atlas and run on Orion Platform 2016.x — 2017.1, such as:

  • NPM 12.0-12.1 without hotfix 1
  • SAM 6.2.4-6.4 without hotfix 1
  • NCM 7.5-7.6 without hotfix 1

 

Cause 

By default, Network Atlas loads every entity that can be displayed on the map, including entity dependencies, properties, and status calculations. In large environments with many entities, map data will either load slowly or the system will timeout due to the amount of data involved.

Resolution

The following workaround applies to existing customers that upgraded to Orion Platform 2016.x — 2017.1 and encountered Network Atlas map issues. If you encounter map issues after upgrading to Orion Platform 2017.3 or 2018.2, see Network Atlas Maps load slowly or do not load in NPM 12.2 and later.

You can resolve this issue in two ways:

  • Stop unwanted entities by modifying the Network Atlas configuration file.
  1. Log in to your Orion server as an administrator.
  2. Navigate to your Network Atlas installation folder, usually located in "C:\Program Files (x86)\SolarWinds\Orion\Network Atlas".
  3. Backup the NetworkAtlas.exe.config file.
  4. Open the NetworkAtlas.config file.
  5. Find the <appSettings> sections.
  6. Uncomment the EntitiesNotInUse section and enter the entities you want to stop loading. Separate each entity by semicolon. For example:

    <add key="EntitiesNotInUse" value="Orion.HardwareHealth.HardwareCategoryStatus;Orion.WirelessHeatMap.AccessPoints;Orion.NPM.CustomPollerAssignmentOnNode;Orion.NPM.CustomPollerAssignmentOnInterface;Orion.HardwareHealth.HardwareItem;Orion.HardwareHealth.HardwareInfo;Orion.DPI.Applications;Orion.IpSla.CCMMonitoring;Orion.APM.Exchange.Application;Orion.APM.IIS.Application;Orion.APM.GenericApplication;Orion.APM.SqlServerApplication;Orion.APM.Wstm.ScheduledTasksStatus;Orion.IpSla.Operations;Orion.IpSla.VoipGateways;Orion.UDT.Port" />

    In the example, only nodes, volumes, interfaces, and containers are loaded.
    If you want to monitor applications, remove entities that being with Orion.APM from the list.
    If the section is not in your config file, add it the section based on the example.

  7. Save the file.
  8. Makes the same changes, including backing up the file, to the web.config file, usually located in c:\inetpub\SolarWinds.  
  9. Save the file, and restart Network Atlas.

The Network Atlas maps load more quickly.

 

 

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