Submit a ticketCall us

AnnouncementsChange Is Inevitable

Get valuable help when it comes to tracking and monitoring changes. SolarWinds® Server Configuration Monitor (SCM) is designed to help you: detect, track, and receive alerts when changes occur, correlate system performance against configuration changes, compare server and application configuration against custom baselines, and verify application and system changes.

Learn more.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > NPM 12 install fails because of old SRM install

NPM 12 install fails because of old SRM install

Created by Michael Almadova, last modified by MindTouch on Jun 23, 2016

Views: 1,159 Votes: 1 Revisions: 6

Updated June 13, 2016

Overview

This article provides brief information and steps to resolve the issue when NPM 12 upgrade fails because of old SRM data found in the database and server registry.

 

Environment

NPM version 11.x and 12

Cause 

SRM registry key and old SRM database tables that still exist. 

Resolution

  1. Drop all SRM tables from the database. Work with a DBA to write a query to remove all SRM_ tables located in the database.
  2. Delete the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SolarWinds\Orion\SRM 

 

 

 

 

Last modified

Tags

Classifications

Public