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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > NPM - IVIM - VMAN - No CPU and Memory Statistics for ESX hosts

NPM - IVIM - VMAN - No CPU and Memory Statistics for ESX hosts

Created by Brian O'Donovan, last modified by Magdalena.Markova on Mar 23, 2018

Views: 117 Votes: 1 Revisions: 6

Updated March 22, 2018

Overview

In the Orion Web Console, there are no CPU and Memory statistics for ESX hosts.

In the VIM.BusinessLayer.log, you can find the following message:

2018-03-07 14:24:55,275 [Scheduler] WARN  SolarWinds.VIM.BusinessLayer.LogHelper - Error deleting file c:\programdata\solarwinds\logs\vim\jobs\VIM.Collector.Jobs_[6380].log - (The process cannot access the file 'c:\programdata\solarwinds\logs\vim\jobs\VIM.Collector.Jobs_[6380].log' because it is being used by another process.).

Environment

  • All versions
  • In this instance NPM 12.1, IVIM 7.1, ESXi 6.5

Cause 

CPU and Memory are polled via VmWare API. There are permissions issues on the server blocking the polling.

Resolution

  1. If you have antivirus software on the server, verify that the antivirus exclusions are in place.
  2. Ensure that there are no permissions issues on the server using the Orion Permission Checker. Manually repair any permission issues flagged by the tool.
  3. Stop all Orion services on the Orion server.
  4. Clear the temp folder:
    C:\Windows\Temp\SolarWinds
  5. Replace Job Engine & Collector SDF files:
    1. Stop all Orion services from Orion Service Manager.
    2. Go to C:\ProgramData\SolarWinds\JobEngineV2\Data\JobEngine35.sdf file and rename it to JobEngine35_OLD.sdf 
    3. Create a copy of C:\ProgramData\SolarWinds\JobEngineV2\Data\JobEngine35 - Blank.sdf and rename it to JobEngine35.sdf.
      This way you have the old one to revert back to and you always have a blank copy in case the issue reoccurs. 
    4. Right-click properties of the JobEngine35.sdf you have created, clear the read-only box, and click OK.
  6. Replace the polling controller:
    1. Stop all Orion services from Orion Service Manager.
    2. Go to C:\ProgramData\SolarWinds\Collector\Data\PollingController.sdf file and rename it to PollingController_OLD.sdf 
    3. Create a copy of C:\ProgramData\SolarWinds\Collector\Data\PollingController - Blank.sdf and rename it to PollingController.sdf
      This way you have the old one to revert back to and you always have a blank copy in case issue reoccurs. 
    4. Right-click properties of the PollingController.sdf you have created, clear the read-only box, and click OK.
    5. Restart all Orion Services.

Suggested Tags:  NPM, IVIM, VMAN, CPU, Memory, ESX, ESXi

 

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