Submit a ticketCall us

WebinarWebinar: A checklist for planning your Network Performance Monitor (NPM) upgrade

Are you ready for your next upgrade? To help you plan smoothly, join this webcast to learn more about, SolarWinds® Orion® Installer, SolarWinds Upgrade Advisor, Upgrades Guides, Training Videos, and other resources available. We’ll share key upgrade planning considerations, lessons learned from customers with practical advice from SolarWinds Product Experts. We’ll also give practical tips to identify the estimated time needed and resources, how to prepare the business and IT staff for changes, ways to plan for required system changes, and more.

Register now.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Message Center does not load

Message Center does not load

Created by Leif Amland, last modified by Brian O'Donovan on Jan 17, 2018

Views: 1,074 Votes: 3 Revisions: 6

Overview

Sometimes when Traps and Syslog tables get too high, it prevents the Message Center from loading due to the amount of data it is trying to display.

 

OrionWeb.log

ERROR:

ERROR OrionMessagesReportControl - (null)  System.ServiceModel.FaultException`1[SolarWinds.Orion.Core.Common.CoreFaultContract]: ProvideFault failed, check fault information. (Fault Detail is equal to SolarWinds.Orion.Core.Common.CoreFaultContract(Unknown): System.Data.SqlClient.SqlException (0x80131904): Arithmetic overflow error converting expression to data type int.
 

The issue here is not the number of traps currently in the database, but the number of traps historically. The TrapID in this instance had huge numbers in the order of 3 billion and higher which is bigger than the max int value of 2147483647.

 

Environment

NPM version 12.0 and NPM 12.1

Resolved in NPM 12.2

 

Cause 

A table has an ID that is too large. Usually, this will only occur in the Traps or Syslog tables. In my instance the issue was caused by the traps table.

 

Resolution

  1. Open the Database Manager from the Orion server.
  2. Load your default database.
  3. Highlight and right-click your database and select 'New Query...'
  4. Enter the following query if the issue is with the Traps table:

TRUNCATE TABLE Traps
TRUNCATE TABLE TrapVarBinds
DBCC CHECKIDENT (Traps, reseed, 1)

  1. Enter the following query if the issue is with the Syslog table:

TRUNCATE TABLE Syslog

DBCC CHECKIDENT (Syslog, reseed, 1)

 

Once these have been cleared, you should be able to open the Message Center successfully.

 

 

Last modified

Tags

Classifications

Public