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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > License Manager error: The License Store is inaccessible. Restore connectivity to Main Poller <Pollername> in order to view or add Licenses

License Manager error: The License Store is inaccessible. Restore connectivity to Main Poller <Pollername> in order to view or add Licenses

Updated April 28, 2017

Overview

The following error is displayed when you access the License Manager in the Orion Web Console:

 

The License Store is inaccessible. Restore connectivity to Main Poller <Pollername> in order to view or add Licenses.

 

1C0E3F9.PNG

 

Environment

  • Orion Platform products with Orion Platform 2016.2 and later, such as NPM 12.0.1  and later

Cause

The Licensing Manager requires that the Business Layer on the main polling engine is running, and the website can access the License Store on the main polling engine. The error occurs in the following situations.

  • The Business Layer host on the main polling engine is down.
  • The connection between the website and the main polling engine is down.
  • DNS issues: the website cannot resolve the hostname of the main polling engine
  • Migration was not completed successfully, and the LicensingMainServerName was not updated in Websettings.
  • BusinesslayerHost is not able to load License Businesslayer

Resolution

Initial troubleshooting steps

  1. Verify that the main polling engine is up.

    If you have deployed High Availability, this is the original primary server (the server specified in Websettings).

  2. Verify that the Business Layer Host on the main polling engine is running:
    1. On the main polling engine, start the Orion Service Manager.
    2. If the Orion Module Engine Service is down, restart it.
    3. Restart SolarWinds Information Services to resolve possible communication issues between SWIS and Business Layer Host.

If these steps do not resolve the issue, continue to troubleshoot DNS issues.

DNS issues

  1. Ping the main polling engine from the webserver with issues, using the hostname.
  2. If the ping is not successful, add the hostname to your hosts file:
    1. Go to C:\Windows\System32\drivers\etc
    2. Open hosts in a text editor, and add a new line with the IP address and hostname of your main polling engine.

      To edit the hosts file, you need to launch the text editor as administrator.

If your issue still persists, review the steps for resolving incomplete migration.

Incomplete migration

If the migration did not complete, the LicensingMainServerName in WebSettings was not updated. Complete the following steps if you are on Orion Platform 2016.2 - 2017.1, for newer versions do the steps on KB linked under step 8:

  1. Log in to the primary polling engine server.
  2. Open a command prompt.
  3. Navigate to c:\Program Files (x86)\SolarWinds\Orion\Licensing\.
  4. Execute the migration.exe /ExpireAll command, and follow the on-screen instructions.
  5. Enter the following: Migration.exe /promote
  6. Open the Orion Service Manager.
  7. Restart the SolarWinds Orion Module Engine service.
    Now, the License Store on the main polling engine is empty. You can access the web-based License Manager now.
  8. Activate the license.

    If your deployment includes offline Additional Polling Engines or Additional Web Servers, run the Configuration Wizard on an Additional Polling Engine to be able to activate licenses in the offline mode.

8.  If you are on a newer version of Orion then the one above do the steps in the following KB,

https://support.solarwinds.com/Succe..._license_store

 

Failed to load License Businesslayer

  1. Look into C:\ProgramData\SolarWinds\Logs\Orion\BusinessLayerHost.log
  2. The following is one of the many errors that can be encountered:
    2017-11-02 00:02:58,230 [7] ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "Orion Licensing Business Layer" failed to start.
    System.ArgumentException: Only the first eight characters of a custom log name are significant, and there is already another log on the system using the first eight characters of the name given. Name given: 'SolarWinds.Net', name of existing log: 'SolarWinds.Net_old'.
       at System.Diagnostics.EventLog.CreateEventSource(EventSourceCreationData sourceData)
       at System.Diagnostics.EventLog.CreateEventSource(String source, String logName)
       at SolarWinds.Orion.Common.SWEventLogging.OpenEventLog()
       at SolarWinds.Orion.Common.SWEventLogging.WriteEntry(String eventMessage, EventLogEntryType logEntryType, Int32 eventId)
       at SolarWinds.Orion.Licensing.BusinessLayer.LicensingBusinessLayerPlugin.Start()
       at SolarWinds.BusinessLayerHost.Contract.BusinessLayerPlugin.Start()
       at SolarWinds.BusinessLayerHost.PluginInstanceAppDomain.Start()
  3. In the above case, renaming the "SolarWinds.Net" event log to "SolarWinds.Net_old" or something similar will cause an exception
  4. The steps to resolve will be to:
    1. Log into Orion server (RDP)
    2. Run > regedit
    3. Navigate to:
      HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\EventLog\
    4. You will notice "SolarWinds.Net_old"
    5. Rename it back to "SolarWinds.Net"
    6. Stop and start all Orion services

 

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