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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Installer could not retrieve Product Catalog

Installer could not retrieve Product Catalog

Updated December 4, 2018

Overview

The SolarWinds Orion Installer could not retrieve a working version of Product Catalog, so was unable to confirm installed versus currently available product versions.

Environment

  • Network Performance Monitor (NPM)
  • Server & Application Monitor (SAM)
  • Network Configuration Manager (NCM)
  • Network Topology Mapper (NTM)
  • Firewall Security Manager (FSM)
  • IP Address Manager (IPAM)
  • VoIP & Network Quality Manager (VNQM)
  • Storage Resource Monitor (SRM)
  • Web Performance Monitor (WPM)
  • User Device Tracker (UDT)
  • Patch Manager
  • Engineer's ToolSet (ETS)
  • Server Configuration Monitor (SCM)

Cause 

Internet access might be restricted, installation file might be corrupted, or the Orion Installer is not compatible with the Administration Service on the main polling engine.

In the case of additional polling engines or HA installations, this may be due to communication between the new server and the main polling engine.

Resolution

When installing or upgrading the main Orion server

  1. Provide Internet access to this address https://downloads.solarwinds.com/.
  1. Download the Orion Installer from the Customer Portal again.
  2. If your environment includes SolarWinds High Availability (HA), make sure the HA pool is disabled.
  3. If problems still occur, please enter a helpdesk ticket.  

When installing or upgrading scalability engines (for example, Additional Polling Engines)

Several scenarios can block the Orion Installer, including: 

  • The Orion Installer updated an existing scalability engine before the main Orion server was updated to at least Orion Platform 2017.3 MSP3.
    Resolution: Update the Orion server to at least Orion Platform 2017.3 MSP3, and then rerun the installer on the scalability engines.
  • There is no connection between the scalability engine and the Orion server.
    Resolution: Ensure that there is a good connection between the scalability engine and the Main Server.
  • Time settings are not synced between the scalability engine and the Orion server. Even a few seconds difference can block data from being sent between servers. Multiple time zones are not supported.
    Resolution: Ensure time zones and clocks on each server are synchronized.
  • The Orion Installer is not compatible with the Administration Service on the main server (for example, Orion Installer version 2.0 and Adminstration Service 2.1+).
    Resolution: Download and run (just initialize and close) the latest Orion installer on the main server, then use the new installer on the scalability engine.
  • Restart the Administration service on the main polling engine.
 

 

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