Submit a ticketCall us

AnnouncementsFace your biggest database issues head-on

Our new eCourse helps you navigate SQL Server performance blocks by teaching you how to recognize and deal with the three DBA Disruptors: Performance Hog, Blame Shifter, and Query Blocker. Register today to learn how to defend your environment and fend off menacing disruptions.

Register for your free eCourse.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Hardware Health sensors on IBM x3650 M4 stopped working

Hardware Health sensors on IBM x3650 M4 stopped working

Created by Kevin Twomey, last modified by MindTouch on Jun 23, 2016

Views: 1,219 Votes: 0 Revisions: 3

Overview

Hardware Health sensors on IBM x3650 M4 have stopped running and returns empty snmpwalk files for every OID.

Example:

NodeID                2102
Vendor                 IBM x3650 M4
Machine              Windows 2003 Server
IP-Name              10.0.0.1 - IBM Server     

HWH polling Method  4 = SNMPIBM.
HWHLastPoll Status   0  Unknown
HWHLastPolldate       2015-09-13  8pm
HWH Status                  isDisabled = True

 

APM_HardwareInfo

NodeID

Polling
​Method

Manufacturer

LastPollTime

LastPollStatus

2102

4

IBM

2015-09-13T20:33:08.9130000

0

1526

1

IBM

2016-03-22T08:57:10.2230000

1

1528

1

IBM

-03-22T08:59:34.5400000

1

1529

1

IBM

2016-03-22T09:00:27.1570000

1
 

[APM_HardwareInfo.PollingMethod]

  • 0 Unknown
  • 1 VMware                Direct ESX polling (CIM polling)
  • 2 SNMPDell
  • 3 SNMPHP
  • 4 SNMPIBM
  • 5  VMwareAPI          (Through vCenter VMware API)
  • 6 WmiDell
  • 7 WmiHP
  • 8 WmiIBM

Environment

  • NPM 11.5.2
  • SAM 6.2.3

 

Cause 

This can occur when a server is disabled as shown in the Hardware Health tables.

Resolution

This can be resolved using the following options:

Option 1

Run the following query in SQL Server Management Studio or Database Manager against the Orion database.:

Update APM_HardwareInfo
Set isdisabled=0
where NodeID = 2102

Option 2

  1. Reinstall the agents (ServeRAID and IBM) on the devices.
  2. Manually stop the services.
  3. Start the services in the following order:
    • ServeRAID
    • IBM Common Agent Services
    • Windows SNMP Service
Last modified

Tags

Classifications

Public
/*]]>*/