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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Configuration Wizard: Cannot add index (PK_configwizardlog)

Configuration Wizard: Cannot add index (PK_configwizardlog)

Created by Giane Ira, last modified by Mariusz Handke on Nov 03, 2016

Views: 2,329 Votes: 5 Revisions: 12

Overview

An error similar to the following appears during Configuration Wizard:

Cannot add index (PK_ConfigWizardLog)

Environment

All NPM versions

Cause 

  • The database has reached the size limit.
  • There are incomplete permissions for the SQL account.
  • Duplicate rows (duplicate LogID values) in ConfigWizardLog table

Resolution

Log into the database and verify that there is available space.
If the database is full, create space by truncating the following:

  1. Open the Syslog table and run Truncate Table Syslog.
  2. Open the Traps table and run Truncate Table Traps.
  3. Open the TrapVarbinds table and run Truncate Table TrapVarbinds.

If disk space is not the issue,

  1. Make sure the SQL account being used has the dbcreator, db_owner and securityadmin permissions.

    2. Re-run the Configuration Wizard.

 

If the error persists after doing all of the above run the following SQL command to drop the Configwizardlog table MAKE SURE YOU HAVE A DB BACKUP

- Drop table dbo.configwizardlog

 

Preferable approach, in order to retain logs, would be to find duplicate rows in the ConfigWizardLog table and remove duplicates. Below query will list LogID values which have duplicates:

SELECT LogID
FROM [dbo].[ConfigWizardLog]
GROUP BY LogID
HAVING (COUNT(LogID) > 1)

 

Below query will list complete rows, with time-stamps, to help you decide which rows to delete:

SELECT *
FROM [dbo].[ConfigWizardLog]
WHERE LogID IN (
SELECT LogID
FROM [dbo].[ConfigWizardLog]
GROUP BY LogID
HAVING (COUNT(LogID) > 1)
)
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