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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Cisco ACI polling failed in NPM

Cisco ACI polling failed in NPM

Updated: December 4, 2018

Overview

When the Orion Web Console displays the Cisco ACI polling failed message, verify the polling settings for the Cisco ACI node.

Environment

  • NPM 12.4 and later

Cause

The message is displayed in the following cases:

  • You have just added the Cisco ACI node to NPM for monitoring and no data has been polled yet.
  • There are polling issues.

Resolution

No data polled yet

If you have just added the Cisco node for polling, wait a few minutes for the data to be polled and displayed.

 

Polling issues

If you are monitoring the node longer than the period set as the status polling interval (by default, it is 2 minutes), verify the node status:

  • If the node is not up, NPM has problems reaching the node. Ensure that the device is working and that no firewall is blocking the traffic from the device to NPM.
  • If the node is up, ICMP polling works but NPM cannot poll Cisco ACI data through the REST API.
    • Make sure that you have provided correct credentials for Cisco ACI. On the Node details page, click Edit Node, ensure that Poll for Cisco ACI is selected and double-check the credentials.
    • Verify that no firewall is blocking the traffic for the Cisco ACI REST API data.

 

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