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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Alerts are not resetting and errors in logs pertaining to MSDTC

Alerts are not resetting and errors in logs pertaining to MSDTC

Updated June 27, 2018

Overview

 

In versions of the Orion platform older than Core 2018.1 you may find issues with performance, alerts not being sent or reset correctly and sql connectivity issues.

 

Upon inspecting the alerting service log file as per below

 

C:\ProgramData\SolarWinds\Logs\Orion\Alerting.Service.V2.log:

 

You can find an error such as:

 

ERROR SolarWinds.Orion.Common.SWEventLogging - Service was unable to open new database connection when requested.
TransactionManagerCommunicationException: Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administrative tool.
System.Transactions.TransactionManagerCommunicationException: Network access for Distributed Transaction Manager (MSDTC) has been disabled. Please enable DTC for network access in the security configuration for MSDTC using the Component Services Administrative tool. ---> System.Runtime.InteropServices.COMException: The transaction manager has disabled its support for remote/network transactions. (Exception from HRESULT: 0x8004D024)

Environment

  • Modules using Orion Core 2017.3 and earlier (example, NPM 12.2)

Cause 

  • The issue is caused by a security restriction from the MSDTC service protocols between the SQL server and all the SolarWinds Servers.

Resolution

Please perform the following steps on the SQL and all the SolarWinds Servers.

  1. Open a Run command on the server.
  2. Type dcomcnfg.
  3. Click OK to open Component Services.
  4. Expand Component Services.
  5. Expand the following:
  6. Computers
  7. My Computer
  8. Distributed Transaction Coordinator 
  9. Click Local DTC.
  10. Right-click Local DTC and select Properties to display the Local DTC Properties dialog box.
  11. Click the Security tab.
  12. Under Security Settings, select the Network DTC Access
  13. Under Transaction Manager Communication, select the Allow Inbound and Allow Outbound checkboxes.
  14. Under Transaction Manager Communication, click the No Authentication Required radio button.
  15. Select the Enable XA Transactions checkbox.
  16. Click OK.

 

Note: It’s recommended that you review your Windows Firewall exceptions to avoid any DTC issues.  Though system and security settings will vary, you can investigate the appropriate exceptions by going to Control Panel > Windows Firewall > Allow apps to communicate through Windows Firewall and to review the exceptions for Distributed Transaction Coordinator.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any

 

 

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