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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > A blocked file prevents SolarWinds from working properly

A blocked file prevents SolarWinds from working properly

Created by Justin Wyllys, last modified by MindTouch Content Copy on Nov 13, 2015

Views: 2,034 Votes: 0 Revisions: 5

Overview

 

If you encounter issues with Orion after installing a hotfix and you see the following error in the logs, you will need to unblock the file listed in the error. 

Depending on what file is blocked, certain parts of NPM may not function properly. The following error means Orion cannot access a file that exists in the install directory.

Example of the error seen in logs:

"ERROR SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerService - Unhandled exception occured when rescheduling discovery jobs

System.Exception: Unhandled exception occurred during loading assembly [SolarWinds.Orion.Core.DiscoveryPlugin] ---> System.IO.FileLoadException: Could not load file or assembly '<file:///D:\ProgramFiles\SolarWinds\Orion\SolarWinds.Orion.Core.DiscoveryPlugin.dll>' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515) ---> System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.

   --- End of inner exception stack trace --- 

Environment

Any Orion core product, typically after a hotfix is installed.

 

Cause 

This can happen when you download a file from the internet, or transfer it from one machine to another before installing.

http://en.wikipedia.org/wiki/Code_Access_Security 

Resolution

  1. Navigate to the file listed in the error message.
  2. Right-click the file > Properties > Unblock > OK​.
  3. Restart services and check the logs again to see if the issue has been fully resolved. 

 

Example:
blocked.png

 

​​Note: If the file is not blocked, you will not see an 'Unblock' button.

 

 

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