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Home > Success Center > Network Performance Monitor (NPM) > Job Engine v2 service crashes

Job Engine v2 service crashes

Created by Ivan Zlatkov, last modified by MindTouch on Jun 23, 2016

Views: 292 Votes: 1 Revisions: 10

Overview

This article provides brief information and steps to resolve the issue when Job Engine v2 service crashes.

 

The Windows Event log should be similar to the following:

2015-10-26 17:33:03,396 [7] FATAL SolarWinds.JobEngine.ServiceProcess.SolarWindsService - OnStart: Unhandled exception caught
System.InvalidTimeZoneException: The time zone ID 'Turkey Standard Time' was found on the local computer, but the registry information was corrupt.

Environment

All Orion Core products

Cause 

The Issue is caused by a corrupted registry value for the Time Zone.

 

Confirm this by comparing the current registry entry from your server with the same one from a working Windows machine, the binary value of TZI is most probably corrupted.

 

jobEngineV2.png

Resolution

Warning: SolarWinds strongly recommends that you create a backup of your registry. This procedure may create permanent changes on your registry.

 

1. Backup your registry.

a. Open the Registry Editor.

b. Right-click on Computer, and select Export.

c. Save the file.

2. Export the same registry key from a working Windows machine. 

a. Open the Registry Editor.

b.Right-click on the target Time Zone key, and select Export.

c. Save the file.

3. Import the registry key you exported from Step 2 to the Windows Server where Orion is running. 

a. Open the Registry Editor.

b. Click File.

c. Click Import.

4. Reboot the server.

 

 

 

Last modified
22:35, 22 Jun 2016

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