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Home > Success Center > Network Performance Monitor (NPM) > JobEngine.v2 SchedulerResults Filling Up

JobEngine.v2 SchedulerResults Filling Up

Created by Jousseff Jaranilla, last modified by Verwin Ubana on Feb 15, 2018

Views: 1,817 Votes: 3 Revisions: 21

Overview

This article provides step by step guide in resolving issues related to JobEngine.v2 SchedulerResults filling up and growing in size exponentially.

Environment

 

  • All Orion Core Versions
  • All NPM Versions

 

Cause

Erroneous JobEngine.v2

Steps

1. Shutdown all Orion Services

Start > All Programs > SolarWinds Orion > Orion Service Manager

Search > Orion Service Manager

2. Navigate to C:\ProgramData\SolarWinds\JobEngine.v2

3. Rename SchedulerResults folder to SchedulerResults.old

4. Click on Start and then click on Run

5. Type %ProgramData% and press Enter

6. Open the following folders: C:\ProgramData\SolarWinds\Installers

7. Right-click the following to uninstall:
    JobEngine.msi
    JobEngine.v2.msi
    CollectorInstaller.msi
    InformationService.msi

8. Once done, go to Orion Service Manager and make sure the SolarWinds Job Engine is Stopped (All services under Orion Services Manager should still be on "stopped" mode)

9. Go back to C:\ProgramData\Solarwinds\Installers, right-click the following to reinstall:
    JobEngine.msi
    JobEngine.v2.msi
    CollectorInstaller.msi
    InformationService.msi

10. Log in to Orion NPM Server as a Windows Local Administrator.

11. Click Start > Control Panel > Programs and Features.

12. Right-click SolarWinds Orion Core Services, and select Repair.
        After the repair, the Configuration Wizard is launched.

13. Complete the Configuration Wizard to complete the repair process.

 

* If any of the services do not want to reinstall, check to see if you have User account control enabled. If so then turn it off and reboot the server and then the service should install. If you have Orion installed on Windows Server 2012 machine, right click on the MSI package > Properties > Compatibility tab > tick 'Run this program in compatibility mode for' and select 'Previous version of Windows'.


14. Go back to Orion Service Manager and click Start Everything to start all services. Please make sure everything is running.
 

 

 

 

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