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Home > Success Center > Network Performance Monitor (NPM) > Installer fails with a socket connection message when installing from the main poller

Installer fails with a socket connection message when installing from the main poller

Updated 12-9-2017

Overview

 

SolarWinds provides an installation package that downloads and installs products from the main polling engine to additional polling engines and additional web servers. This installation is used when creating a High Availability pool member.

 

If the additional polling engine or additional web server has a slow connection to the main poller, the installation might fail with a timeout error. You can locate the error message within the log: Socket connection has been disposed.

 

Each installation file has a download timeout of 30 minutes from the main polling engine to additional systems. Each Orion product will have a file to download to each system. The largest file is the Orion Platform features (about 800MB or more), the next largest is SQL Express (about 300 MB or more). Each file must be transferred within 30 minutes.

Environment

  • Additional Polling Engines (APE)
  • Additional Web Servers (AWS)

Cause 

A slow Internet connection to the main poller causes a timeout when installing on additional polling engines and additional web servers. A timeout occurs if each installation file download takes longer than 30 minutes.

Resolution

  • Check the connectivity in your network to the main polling engine to other systems (Additional Poller \ Web \ HA Backup Servers) receiving the installations.
  • Take actions to help improve data transfer between the systems on your domain to reduce download times and complete the installation within 30 minutes.

    If the above is not possible you can try this workaround:
  1. Run the scalability engines installer again on the Additional Poller \ Web \ HA Backup server you are upgrading and click through until you see a screen right before downloading starts
  2. Copy ‘C:\ProgramData\Solarwinds\Installers\CoreInstaller.msi’ as well as MIBs.msi from main server to server you are upgrading to the following location: %temp%\SWOrionSetup[currenttimestamp]\subinstallers\CORE_2017.x\

  3. Resume from where you left off in Step #1 with the installation of the Additional Poller \ Web \ HA Backup  using the Scalability Engines Installer

  4. This will hopefully upgrade the rest of the software, however, you should note that any unresolved network connectivity issues between Additional Poller \ Web \ HA Backup and the Primary Polling Engine or SQL server may cause you further problems going forwards if this is not addressed.

 

 

 

Last modified
05:03, 13 Sep 2017

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