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Home > Success Center > Network Performance Monitor (NPM) > Installation fails due to Windows code access security

Installation fails due to Windows code access security

Overview

While running the FSM installer, the installation screen disappears and does not show any error.

Note: This happens to both Windows and Admin users. Upon checking the Windows Task Manager, no setup process is running. 

Environment

All versions of NPM

Cause: 

This issue occurs when the installation files are copied from a different machine. When you right click setup.exe > Properties, it shows the following message with an Unblock button:

This file came from another computer and might be blocked to help protect this computer.

All files in the installation folder are also blocked and this happens because of Windows Code Access Security.

Here is an  example stack trace from the core business layer log, where the Core BL is failing to access a discovery plugin:

ERROR SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerrService – unhandled exception occurred when rescheduling discovery jobs
System.Exception: Unhandledd exception occurred during loading assembly [SolarWinds.Orion.Core.DiscoveryPlugin] -à System.IO.FileLoadException: Could not load file or assembly ‘<C:\Program files\SolarWinds\Orion\Solarwinds.Orion.Core.DiscoveryPlugin.dll>’ or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515) -à System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load not intended to sandbox the assembly, please enable the loadFromRemoteSources switch.  See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.
   === End of inner exception stack trace ---

Note:

The above file (Solarwinds.Orion.Core.DiscoveryPlugin.dll) will obviously vary, but the rest of the stack trace is uniform to this issue.

Resolution

  1. Download the Orion installation files to the server where it is to be installed.
  2. Unzip the installation files. The files will not be blocked.
  3. Run the setup.exe file.

Note: The installation should run successfully. If not, check that the User Access Control (UAC) is not blocking the installation.

If this does not work, you can Unblock the files in the installation folder and run the installer again. 

 

Refer to KB 2287 on disabling UAC.

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