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Home > Success Center > Network Performance Monitor (NPM) > Installation error: The installation source for this product is not available

Installation error: The installation source for this product is not available

Created by Michael Perez, last modified by Michael Almadova on Mar 03, 2017

Views: 118 Votes: 5 Revisions: 14

Overview

Scenario 1:  

If you encounter this error during an upgrade, navigate to C:\ProgramData\Solarwinds\OrionInstaller.log

 

This article describes how to resolve the issue when it contains an error similar to below:  

 

2016-03-28 17:16:30,879 [1] INFO  OrionInstallerLib.MsiDatabaseInfo - Found related product "SolarWinds Active Diagnostics 1.2.0.12" v1.2.0.12 already installed.
2016-03-28 17:16:30,958 [1] DEBUG OrionInstallerLib.InstallerInfoProvider - Installer information loaded for SolarWindsActiveDiagnostics.msi
2016-03-28 17:16:30,958 [1] INFO  OrionInstallerLib.InstallerInfoProvider - Loading installer information for CoreInstaller.msi
2016-03-28 17:16:31,004 [1] INFO  OrionInstallerLib.MsiDatabaseInfo - Found related product "SolarWinds Orion Core Services 2015.1.2" v115.1.8197.25300 already installed.
2016-03-28 17:16:32,129 [1] INFO  OrionInstallerLib.MsiDatabaseInfo - Found related product "SolarWinds Orion Core Services 2015.1.2" v115.1.8197.25300 already installed.

2016-03-28 17:16:32,208 [1] FATAL OrionInstaller.Program - Exception: The installation source for this product is not available. Verify that the source exists and that you can access it.
Microsoft.Deployment.WindowsInstaller.InstallerException: The installation source for this product is not available. Verify that the source exists and that you can access it.
   at Microsoft.Deployment.WindowsInstaller.Installer.OpenProduct(String productCode)
   at OrionInstallerLib.MsiDatabaseInfo.FromInstalledProduct(String upgradeCode)
   at OrionInstallerLib.InstallerInfoProvider.MsiConditionCreator(String installerFileName, XElement conditionElement)
   at OrionInstallerLib.InstallerInfoProvider.CreateConditions(String installerFileName, XElement conditionsElement)
   at OrionInstallerLib.InstallerInfoProvider.CreateInstallerInfo(XElement installer)
   at OrionInstallerLib.InstallerInfoProvider.<Load>b__1(XElement x)
   at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at OrionInstallerLib.InstallerInfoProvider.Load(XElement root)
   at OrionInstallerLib.InstallChain.LoadFromXml(XElement root)
   at OrionInstaller.Program.CreateWizard(String[] args)
2016-03-28 17:16:32,270 [1] INFO  OrionInstallerLib.OrionImprovement.OipClient - Tracking event: Orion Standalone Installer -  - Exception: The installation source for this product is not available. Verify that the source exists and that you can access it. - False - 0

 

Scenario 2:

A product installation fails with the error:  "The specified account already exists"

 

When you check the OrionInstaller log you may find errors similar to:

2016-11-29 15:30:10,632 [25] INFO  OrionInstallerLib.MsiDatabaseInfo - Found related product "Microsoft SQL Server 2012 Management Objects " v11.0.2100.60 already installed.

 

 

Environment

  • Any Orion application

 

Cause 

This is caused by a botched install of Core or other ancillary packages (Orion Improvement, etc..).

 

Resolution

  • Please Note:  It is possible more than 1 application will generate this error, you can repeat the steps as needed but DO NOT remove an application that isn't found immediately above the FATAL error (see the example above.).  
  • Scenario 2: Uninstall the application found next to the "already installed" error from Programs and Features.  If that fails with "Invald installation source", proceed with the steps for Scenario 1.
  • Scenario 1:  When an application is found:
  1. Download the Microsoft FixIt tool. (© 2016 Microsoft, available at https://support.microsoft.com, obtained on November 17, 2016.)
  2. Use the FixIt tool to remove the application causing the issue.  As seen in the example above, this is the application immediately above the FATAL error.  This should allow for the installation to proceed without error
  • When the MIB is responsible:
    1. Go into the Control Panel on the and remove the "SolarWinds MIBs". This should resolve the MIB error and allow installation to proceed without error

 

Note:  These steps might need to be repeated several times in the event that more than one package presents the error.  Each time you will be presented with a unique name string before the FATAL error.  

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

If fix-it tool does not fix the problem for NetflowTraffic Analyzer do the following:

 

1. Open Regedit

2. Navigate to HKEY_LOCAL_MACHINE > SOFTWARE >Wow6432Node > Solarwinds > Orion 

3. Export Netflow Traffic Analyzer & Netflow Traffic Analyzer Installer 

4. After having a safe backup of the 2 registry keys you can delete these 2. 

5. Run NTA installer and should now allow you to fix NTA. 

 

Suggested tags:  Invalid Install Source, Product: NPM, Stage: Draft

 

Reason for Rework or Feedback from Technical Content Review: 

Michael Perez:  Originally the steps to remove the registry entry, this was re-worked to avoid issues generated within support.

Last modified
14:46, 3 Mar 2017

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