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Home > Success Center > Network Performance Monitor (NPM) > Information service error: A call to SSPI failed, see inner exception

Information service error: A call to SSPI failed, see inner exception

Created by Adrian Cook, last modified by Brian.Kiely on Feb 09, 2017

Views: 1,797 Votes: 3 Revisions: 6

Overview

The Business layer is unable to connect to SWIS and the Information Service v3 logs displays the following error:

 

2016-04-29 09:51:25,257 [12] ERROR SolarWinds.InformationService.Contract2.InfoServiceProxy - (null)     An error occurrred opening a connection to the orion communication service.
System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception. ---> System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception. ---> System.ComponentModel.Win32Exception: The Local Security Authority cannot be contacted

Environment

All Orion Platform versions

Cause 

The error is caused by changes made in Windows updates. See Microsoft KB 3081320, MS15-121: Security update for Schannel to address spoofing: November 10, 2015 (© 2016 Microsoft, available at https://support.microsoft.com, obtained on May 3, 2016.)

Resolution

  1. Click Start > Run.
  2. Enter regedit in the Open box on the Orion Server, and then click OK.
  3. Locate and then click the following subkey in the registry:
    HKLM\System\CurrentControlSet\Control\SecurityProviders\Schannel
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. For the computer that is receiving the connection request, enter DisableServerExtendedMasterSecret: REG_DWORD for the name of the DWORD, and then press ENTER.
  6. Right-click the new DWORD entry, and then click Modify.
  7. Enter 1 (or any non-zero value) in the Value data field to disable the TLS extension.
  8. Restart the Orion Services.

 

Further information is available from Stack over flow

http://stackoverflow.com/questions/3...79567#30479567

 

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