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Incorrect Hardware Health Status on VMWare Node

Created by Robert Stidman, last modified by MindTouch on Jun 23, 2016

Views: 492 Votes: 2 Revisions: 3

Updated June 1, 2016

Overview

This article provides brief information and steps to resolve the issue where nodes polling with VMware credentials to get statistics have hardware health objects with incorrect status compared to the Vcenter hardware health.

 

Environment

Any Orion with hardware health and the VIM module

 

Cause 

The issue is caused by "poll through vcenter".  The Vcenter has not been updated by the host machine properly.

 

Resolution

Note: If the node is "polling through Vcenter", change it to "poll through ESX" in the Orion Virtualization Settings page.

The Hardware Health monitoring is enabled for all ESX servers automatically and you cannot enable/disable it manually. VMWare type of node can be polled for Hardware information two different ways:

A. Through vCenter
B. Directly by using CIM protocol (ESXpolling)

Polling through vCenter is using VMWare native API interface. Polling ESX server directly is using CIM protocol for get the Hardware information. 
You can use following steps to determine if node is polled through the vCenter or directly:

Go to VMWare Settings page. You can get there from Settings - Node & Group Management.

11.png

A table of all currently polled VMWare nodes will be available. This table contains column Polling Through. It is possible to hide this column.

If poll through vcenter must be used, refer to section 1.3.1 of the article below:

https://support.solarwinds.com/?titl...shooting_Guide

 

 

Last modified
22:30, 22 Jun 2016

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