Submit a ticketCall us

Get a crash course on Network Monitoring delivered right to your inbox
This free 7-day email course provides a primer to the philosophy, theory, and fundamental concepts involved in IT monitoring. Lessons will explain not only how to perform various monitoring tasks, but why and when you should use them. Sign up now.

Home > Success Center > Network Performance Monitor (NPM) > Incompatible Orion modules found

Incompatible Orion modules found

Updated October 26, 2016

Overview

This article addresses the  issue where an additional polling engine cannot proceed in upgrading to NPM 12.0.1 poller as the VNQM module is found incompatible.

Environment

  • NPM 12.0 and later

  • VNQM 4.2.3 and later

Cause 

Primary Poller:

  • NPM 12.0.1
  • VNQM 4.2.4

 

The additional poller is running NPM 12.0 with VNQM 4.2.3. Updating the poller to NPM 12.0.1 will not proceed as it detected the VNQM 4.2.3 as an incompatible module. You also cannot update the VNQM to 4.2.4 because that version requires NPM 12.0.1. 

 

Running the NPM 12.0.1 Additional Polling Engine installer shows the message below:

 

Resolution

  1. On the additional poller, uninstall VNQM 4.2.3 via Windows Control Panel > Add/Remove Programs.

  2. Once uninstalled, cancel the Configuration Wizard.

  3. Open Windows Registry. Start > Run > Regedit.

  4. Navigate to this directory: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Solarwinds\Orion.

  5. Right click the VoIP Monitor folder and select Delete.

    Note: You can also create a backup of this registry through export - Right click > Export.

  6. Once deleted, run the NPM 12.0.1 additional polling engine installer. This should proceed on installing the NPM 12.0.1 without any issues.

  7. Once NPM 12.0.1 additional poller is updated, proceed on installing VNQM 4.2.4 poller.

 

Last modified
16:40, 25 Oct 2016

Tags

Classifications

Public