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Home > Success Center > Network Performance Monitor (NPM) > HA installation error: Can't receive data from SolarWinds Administration Service

HA installation error: Can't receive data from SolarWinds Administration Service

Updated April 17, 2017

Overview

The following error is displayed on the High Availability (HA) server when running the SolarWinds Orion installer for HA:

SolarWinds Orion Compatibility Check

Can't receive data from SolarWinds Administration Service

 

 

The following error is displayed in the Administration log:

The log file is located in: 

C:\ProgramData\SolarWinds\logs\Orion\Administrationservice 

 

ERROR SolarWinds.Administration.HAInstaller.WCF.FileTransferService - GetPackageFileStream
System.IO.FileNotFoundException: Failed to locate package file.
File name: 'C:\ProgramData\SolarWinds\Installers\CoreInstaller.msi'

 

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The log file is located in: 

C:\ProgramData\Solarwinds\Logs\Installer\<install log folder>\CompatibilityPreInstaller.log

 

ERROR SolarWinds.Orion.CompatibilityPreInstaller.Forms.DownloadProgressPage - System.ArgumentOutOfRangeException: Value of '101' is not valid for 'Value'. 'Value' should be between 'minimum' and 'maximum'.
Parameter name: Value
   at OrionInstallerLib.FileTransfer.FileTransferProxyClient.GetFile(FileInfo fileInfo, Action`1 reportProgress)
   at SolarWinds.Orion.CompatibilityPreInstaller.Forms.DownloadProgressPage.DownloadFile(String fullPath, Action`1 setDownloadedBytes)
   at SolarWinds.Orion.CompatibilityPreInstaller.Forms.DownloadProgressPage.backgroundWorker_DoWork(Object sender, DoWorkEventArgs e)

 

 

Environment

  • NPM 12.2
  • HA Server
  • APE Server

Cause

This occurs when installers are missing from the primary server. 

Resolution

  1. Check the Installers folder in the primary server to determine the missing installer. This is located in C:\ProgramData\SolarWinds\Installers by default.
  2. Download the missing installer from the SolarWinds Customer Portal.
    Note: Verify that it is the same as the version installed on the primary server.
  3. Run the installer.
  4. Go to the SolarWinds folder in %appdata%. This is where the temp installers are placed during extraction.
    Note: If %appdata% does not show the temp installers, copy the installer from an additional polling engine.
  5. Copy the missing installer to the Installers folder.  
  6. Rerun the installer on the HA server.

If the issue persists, more installers are still missing. Repeat the steps and verify that all missing installers are identified.

 

 

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