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Home > Success Center > Network Performance Monitor (NPM) > Event Log Errors: Application and .NET Runtime errors referencing JobEngine.v2

Event Log Errors: Application and .NET Runtime errors referencing JobEngine.v2

Updated March 11th, 2016

Overview

This article is a follow up to this KB article listed here. Once you follow the KB, the Job Scheduler and Job Engine v2 wouldn't start successfully. You end up removing four of the services and manually reinstalling them resolving both errors.

Environment

All versions of NPM

Cause 

This issue occurs because of some corruption in the services causing the JobEngine.v2 and the Job Scheduler to stop working.

 

Resolution

  1. Navigate to C:\ProgramData\Solarwinds\Installers.
  2. Stop all the Services using the Orion Service Manager. 
  3. Select Shutdown Everything.
  4. In this order, remove the following by double-clicking each installer and selecting Remove.
    1. CollectorInstaller
    2. InformationService
    3. JobEngine
    4. JobEngine.v2
  5. Reinstall the services in the same order:
    1. CollectorInstaller - Select Complete Option
    2. InformationService - Select Complete Option
    3. JobEngine - Select Complete Option
    4. JobEngine.v2 - Select Comlpete Option.
  6. Go back to the Orion Service Manager and select Start Everything.

 

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