Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Network Performance Monitor (NPM) > Event 10028 "DCOM was unable to communicate with the computer"

Event 10028 "DCOM was unable to communicate with the computer"

Created by Jousseff Jaranilla, last modified by Tiarnan Stacke on Oct 18, 2017

Views: 17,524 Votes: 4 Revisions: 31

Overview


This article provides information regarding the root cause of Event 10028 "DCOM was unable to communicate with the computer" and how to address this issue or verify that it is a genuine error. 
 

 

Related Errors from DataProcessor.log:

Note: NPM 12 moved this to Collector\Logs\Collector.Service.Log

 

2016-05-12 15:43:56,722 [STP ProcessingPipeLine Thread #401] ERROR DataPreProcessing - Processing result: PollerResultWrapper: PollerType=V.Status.WMI.Windows, NetObject=V:79 ErrorCode=800705AF, ErrorMessage= Scope: IPAddress\root\CIMV2[\chcrr\svc_chcsw] ErrorCode: 0x800705AF

 

2016-05-12 15:43:44,628 [STP ProcessingPipeLine Thread #400] ERROR DataPreProcessing - Processing result: PollerResultWrapper: PollerType=N.Memory.WMI.Windows, NetObject=N:222 ErrorCode=800705AF, ErrorMessage= Scope: IPAddress\root\CIMV2[\chcrr\svc_chcsw] ErrorCode: 0x800705AF

 

 

 

Environment

  • All versions of Orion products
  • All Solarwinds Products using WMI / RPC as polling Method. 
  • Windows Server 2008
  • Windows Server 2012
  • Windows Server 2016

Cause

Event 10028 DCOM error occurs when the WMI request failed to communicate with a remote node due to Invalid Credentials or an Invalid WMI Namespace on the Target Device. As a result an event is being logged automatically on your Application Server's Event Logs.

Steps

1. Navigate to the directory from the Orion Server to verify nodes experiencing WMI challenge request (C:\ProgramData\Solarwinds\Collector\Logs)
 

2. Look for the CollectorService.log and manually search the nodes in question using the keyword CIMV2.
 

3. To Verify the Error is genuine you can perform a Wbemtest to verify if the credentials set are valid.

    a. Type wbemtest in the run dialog box.

    b. Under Namespace change root\default to root\CIMV2 then click Connect.

    c. If a second dialog box appears, repeat step a.

    d. Click Enum Classes, select Recursive, and then click OK.

You should see a display of all the CIM objects

 

3. You can also double check stored credentials in Orion to check validity by going through the following steps:

   a. Go to Orion Web Console > Settings > Manage Windows Credentials.

 

4. Another Location for Credentials if you have SAM installed:

   a. Go to Orion Web Console > Settings > Sam Settings > Credentials Library. 

 

 

Last modified

Tags

Classifications

Public