Submit a ticketCall us

Bridging the ITSM Divide
Integrated help desk and remote support software for faster resolution

Join us on Wednesday, November 29, 2017 at 11 a.m. CT, as we discuss the benefits of effectively integrating your help desk software with remote support solutions to help increase the efficiency of IT administration, improve communication, and decrease mean time to resolution (MTTR) for IT issues of all sizes. This directly impacts end-user satisfaction and your business’ bottom line. Register Now.

Home > Success Center > Network Performance Monitor (NPM) > Errors in website functionality, for example top menu disappears

Errors in website functionality, for example top menu disappears

Updated September 13th, 2017

Overview

You may experience different errors in website functionality if the IIS IP Address and Domain Restriction module blocks access to the Orion website for local IP addresses.

For example, if the top menu disappears.

 

Errors similar to the following are in the Orionweb.log when this occurs:

ERROR SolarWinds.Orion.Web.Platform.ApiRequest - (null) Request failed to: http://10.x.x.x.x/api2/features/
ERROR SolarWinds.Orion.Web.UI.SWTab - (null) Failure retrieving view groups.
System.Net.WebException: The remote server returned an error: (403) Forbidden.
at System.Net.HttpWebRequest.GetResponse()
at SolarWinds.Orion.Web.Platform.ApiRequest.Send[TResult,TBody](String resource, String method, TBody body)

Environment

  • Orion Platform 2017.1 or later

 

Cause 

The IP Address and Domain Restriction feature is installed and enabled in IIS and local IP addresses are blocked by the feature configuration.

In the course of normal functionality, the Orion website makes requests to fulfill internal requirements to build parts of the Orion Web Console interface, such as the top menu or views.
Those requests are made using interface IP addresses, including loopback interface.
You may experience different errors in website functionality if those IP addresses are blocked.

 

Resolution

Make sure that all local IP addresses on the server where the Orion website is running are allowed to access the Orion website on the same machine.

  1. Open IIS Manager.
  2. Locate and click SolarWinds NetPerfMon site.
  3. In the IIS section, double-click the IP Address and Domain Restriction feature icon.
  4. Review and edit rules. Make sure that all Orion website local IP addresses are allowed. 

Pay attention to the order of rules and if unspecified IP addresses are allowed or blocked.

More information about IP Address and Domain Restriction feature configuration can be found in the IIS documentation
https://technet.microsoft.com/en-us/library/hh831785(v=ws.11).aspx (© 2017 Microsoft, available at https://technet.microsoft.com/, obtained on September 12, 2017).

 

 

Last modified

Tags

Classifications

Public