Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > Error when launching web console: ProfileCommon cannot be cast to [B]ProfileCommon.

Error when launching web console: ProfileCommon cannot be cast to [B]ProfileCommon.

Updated August 17, 2016

Overview

The following error occurs when launching the web console:

Error:

ProfileCommon cannot be cast to [B]ProfileCommon. Type A originates from 'App_Code.vm78yknh, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' in the context 'Default' at location 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\6faafa1c\92094bad\App_Code.vm78yknh.dll'. Type B originates from 'App_Code.obf7pct9, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' in the context 'Default' at location 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\6faafa1c\92094bad\App_Code.obf7pct9.dll'.

 

Environment

All NPM versions

 

Cause 

The issue is caused by corrupted ASP .NET cache files with insufficient access because of an antivirus program or a locked down system. See Files and directories to exclude from antivirus scanning

 

Resolution

Clear out the ASP .NET cache. See How to clear .Net caches manually for steps. 

 

 

 

Last modified

Tags

Classifications

Public