Submit a ticketCall us

WebinarUpcoming Webinar: How Help Desk and Remote Support Pays for Itself

Learn how help desk software can simplify ticketing management, allow you to track hardware and software assets, and accelerate the speed of IT support and service delivery. Gain insights on how remote support tools allow your IT team to maximize their efficiency and ticket resolution by expediting desktop troubleshooting, ultimately helping keep end-users happy and productive.

Register here.

Home > Success Center > Network Performance Monitor (NPM) > ERROR SolarWinds.Collector.Scheduler.ScheduledTask - InitializeDataprocessor threw an exception.System.Messaging.MessageQueueException (0x80004005)

ERROR SolarWinds.Collector.Scheduler.ScheduledTask - InitializeDataprocessor threw an exception.System.Messaging.MessageQueueException (0x80004005)

Table of contents
Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 881 Votes: 0 Revisions: 10

Issue:

NPM Polling stops with an error in the data processor (DP) logs:

ERROR SolarWinds.Collector.Scheduler.ScheduledTask - InitializeDataprocessor threw 
an exception.System.Messaging.MessageQueueException (0x80004005)

Cause:

The NPM performance counters are not working due to a permission issue with the MSMQ folder.

Resolution:

  1. Go to the folder C:\Windows\System32\msmq using Windows Explorer.
  2. Right-click on the msmq folder and select Properties.
  3. Click Security > Edit to add permissions to an existing User Account.
  4. Click Add to add a new user account.
  5. Enter the name of the user account as Network Service, and then assign the Full Control permission.
  6. Click OK.
Last modified

Tags

Classifications

Public