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Home > Success Center > Network Performance Monitor (NPM) > ERROR SceneContainer:bntNext_Click: ExceptionLogger - System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SqlServer.Smo,

ERROR SceneContainer:bntNext_Click: ExceptionLogger - System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SqlServer.Smo,

Created by Eric Bryant, last modified by Jonathon.Privett on Dec 29, 2017

Views: 3,403 Votes: 2 Revisions: 10

Overview

This article explains how to resolve a behavior when you are trying to click through the first part of the Configuration Wizard during a SQL connection and nothing happens. When looking in the Configuration Wizard logs during this time, you see errors such as the following:

ERROR SceneContainer:bntNext_Click: ExceptionLogger - System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SqlServer.Smo,

 

The following error may also appear in this issue:

ERROR SceneContainer - SceneContainer:bntNext_Click: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SqlServer.ConnectionInfo, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.

Environment

All versions of Orion products

Cause 

This issue occurs when a you attempt to uninstall local SQL instance and removes CLR types from the server which Orion needs to run for remote SQL connection.

Resolution

1. Download and install the following CLR types for the latest versions of Orion:

Downloads can be found in the entire pack or found when you expand the install instructions for both the x86 and x64 CLR types. Both are required to resolve the issue:

https://www.microsoft.com/en-us/down....aspx?id=29065

2. Verify the environment has x64 and x86 versions of Microsoft SQL Server Compact 3.5 SP1 https://stackoverflow.com/questions/...-sfc-version-1

3. Verify customer also has the SharedManagementObjects (x86 and x64) for their sql db type:

https://stackoverflow.com/questions/...-sfc-version-1

4. Run through the Configuration Wizard once more and connect up to SQL:

http://www.solarwinds.com/documentat...=configuration

5. In some instances, you may need to troubleshoot SQL connection even further. Click the link below to know more:

https://solarwinds-prod.mindtouch.us...mission_Issues

 

I highly recommend checking or re-running configuration wizard -> re-checking the configuration wizard log in C:\programdata\programfiles\solarwinds\logs\orion\configurationwizard.log to see if the error changes after installing dependencies above.

This usually occurs because the install packages were taken from the old server and not from the customer portal.

I would recommend overviewing the software requirements section of the products being installed and verifying that all software is installed before running config wizard whenever possible.

 

 

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