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Home > Success Center > Network Performance Monitor (NPM) > Disk space alert does not trigger for Exchange Servers

Disk space alert does not trigger for Exchange Servers

Created by Kevin Twomey, last modified by MindTouch on Jun 23, 2016

Views: 23 Votes: 0 Revisions: 4

Overview

This article provides brief information and steps to resolve the issue when Disk space alert does not trigger for Exchange Servers.

2 Exchange Servers ran out of disk and no alerts were trigggered: 

  • This resulted in exchange database being down impacting email services.
  • There is no entry in Event and Alert tabs on 10/03 for this node for the disk space issue on R drive. 
  • R drive ran out of disk space on 10th March which caused the Exchange database to go down.

Environment

NPM version  11.5.2

Cause 

DB Tables and Diagnostics proved R: Drive was added to some exchange Servers and on other ones it did not trigger as it was not added at that point in ti,e. G Drive triggered fine on same day.
R: Drives Added recently had much higher Volume IDs.

Example:

Exchange Servers:

NodeID

ObjectSubType

Caption

IOSVersion

249

WMI

AMAIL02

Windows 2012 Server

250

WMI

AMAIL01

Windows 2012 Server

251

WMI

BMAIL02

Windows 2012 Server

252

WMI

BMAIL01

Windows 2012 Server

Node:

  • NodeiD               111
  • Node Name       BMail02
  • MachineType    Windows Server 2012
  • PollingVia            WMI

Volumes

  • VolumeC            Used= 83%     ID=2622     C:\ Label:OSDisk 65667D9B0
  • VolumeD            Used= 47%     ID=2623      D:\ Label: EEE31F4B
  •  

NodeID

VolumeID

VolIndex

Caption

VolumePercentUsed

VolSpaceUsed

VolSpaceAvail

VolumeSize

Status

VolumeResponding

111

2620

1

Physical Memory

19.01

6530150400

27829116928

34359267328

1

Y

111

2621

2

Virtual Memory

18.58

7182680064

31471554560

38654234624

1

Y

111

2622

4

C:\ Label:OSDisk 0C07D9B0

83.40

56875360256

11318775808

68194136064

1

Y

111

2623

5

D:\ Label: EEE31F4B

47.71

20489826304

22456696832

42946523136

1

Y

Resolution

To resolve this in Future, simply LIST Resources on those  Exchange Servers and tick all Drives needing to be monitored. R: Drive in this instance. 

Node Details Page or Manage Nodes > List Resource > Add R: Drive and save.

 

Useful Queries to troubleshoot:

 

AlertsHistoryView
SELECT TOP 2000 * FROM [dbo].[AlertHistoryView]
where RelatedNodeID = 251
order by timestamp desc


Volumes
SELECT TOP 5000 * FROM [dbo].[VolumeUsage_Detail]
where volumeID = 2617
order by Datetime desc

SELECT TOP 5000 * FROM [dbo].[VolumeUsage_Hourly]
where volumeID = 2617
order by Datetime desc

 

Events:
select top 5000 * from Events
where NetworkNode = 251
order by eventTime desc

EventID

EventTime

NetworkNode

EventType

Message

1455259

2016-03-22T13:45:

111

5000

G: Drive: Warning Memory Utilisation (>90% <95%) - Windows 95 This alert reports the percentage of physical memory being used on Windows devices.

1455253

2016-03-22T13:43:

111

5000

G: Drive:Warning Memory Utilisation (>90% <95%) - Windows 95 This alert reports the percentage of physical memory being used on Windows devices.

1455252

2016-03-22T13:43:

111

5000

G: Drive:Warning Memory Utilisation (>90% <95%) - Windows 95 This alert reports the percentage of physical memory being used on Windows devices.

1455143

2016-03-22T11:25:

111

5000

G: Drive:Warning Memory Utilisation (>90% <95%) - Windows 95 This alert reports the percentage of physical memory being used on Windows devices.

 

 

 

Last modified
22:11, 22 Jun 2016

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