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Home > Success Center > Network Performance Monitor (NPM) > Custom SQL variables in emails do not work when trigger condition requires multiple objects to trigger alert

Custom SQL variables in emails do not work when trigger condition requires multiple objects to trigger alert

Updated December 1, 2016

Overview

When an alert triggers with a Custom SQL variable in the email title/body, the variable does not display the results in the email. Instead it will display something like the following:
${SQL: SELECT Count(NodeID) FROM NodesData WHERE Status = '2'}

 

The above issue only occurs where the Trigger Condition has "Enable Complex conditions" selected and where the option "Alert can be triggered if more or equal '2' objects (at the same time) have met the specified condition and then trigger single alert" is selected.

 

 

The issue only occurs in the actual email sent from the Alert Triggering. The issue does not occur at all with the "Simulate" function.

Environment

  • NPM 11.5.x
  • SAM 6.2.0, 6.2.1, 6.2.2, 6.2.3

Cause 

A bug in the product.

Resolution

This issue has been resolved in the scope of other alerting engine changes/fixes.To resolve this issue please upgrade to NPM 12.0.1/SAM 6.3.

 

 

Last modified
18:52, 30 Nov 2016

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Public