Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Network Performance Monitor (NPM) > Core Business Layer plugin does not start

Core Business Layer plugin does not start

Updated June 23, 2017

Overview

The Core Business Layer plugin does not start and the following error is found in the Core.BusinessLayer.log file:

2017-03-28 09:51:08,918 [7] FATAL SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin - (null)  Unhandled Exception caught in plugin startup.
System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at SolarWinds.Orion.Core.BusinessLayer.BackgroundInventory.InventoryManager..ctor(Int32 engineID)
   at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin.ScheduleBackgroundInventory()
   at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin.Start()

Environment

All Orion Platform versions

Cause 

This issue occurs when there is a duplicate or an older DLL present in the installation folder.

Resolution

Remove the duplicate DLLS.

Note: It is also possible that there are duplicate DLLs in a duplicate installation folder and in the backup and hotfix folders.

 

Last modified

Tags

Classifications

Public