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Home > Success Center > Network Performance Monitor (NPM) > Configuration Wizard error: Timeout expired error when connecting to SQL Server

Configuration Wizard error: Timeout expired error when connecting to SQL Server

Updated March 11th, 2016

Overview

This article provides brief information and a resolution for the following error: 

Cannot connect to the SQL Server. The original error is: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

 

The error occurs when the Configuration Wizard attempts to configure your database. This is an indication that your Orion server is unable to create a connection to your SQL Server.

 

To confirm, open the Configuration Wizard Log (ConfigurationWizard.log), and search for the following error:

 

Note: The default location of the Configuration Wizard Log is C:\Documents and Settings\All Users\Application Data\SolarWinds\Logs\Orion\ConfigurationWizard.log. 

 

ERROR SettingsController - Error while trying to read 'Enable Windows Login' setting. Details: System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

Environment

All Orion Core products

 

Cause 

The error is caused by a firewall to your network.

 

Resolution

Create an inbound firewall exception for the Dynamic SQL Server port used by the named SQL instance your are using for your Orion installation. 

 

 

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