Submit a ticketCall us

Announcing NCM 7.7
With NCM 7.7, you can examine the rules that make up an access control list for a Cisco ASA device. Then you can apply filters to display only rules that meet the specified criteria, order the rules by line number or by the hit count, and much more.
See new features and improvements.

Home > Success Center > Network Performance Monitor (NPM) > Configuration Wizard error: Timeout expired error when connecting to SQL Server

Configuration Wizard error: Timeout expired error when connecting to SQL Server

Created by Aileen de Lara_ret, last modified by MindTouch on Jun 23, 2016

Views: 727 Votes: 0 Revisions: 2

Overview

This article provides brief information and a resolution for the following error: 

Cannot connect to the SQL Server. The original error is: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

 

The error occurs when the Configuration Wizard attempts to configure your database. This is an indication that your Orion server is unable to create a connection to your SQL Server.

 

To confirm, open the Configuration Wizard Log (ConfigurationWizard.log), and search for the following error:

 

Note: The default location of the Configuration Wizard Log is C:\Documents and Settings\All Users\Application Data\SolarWinds\Logs\Orion\ConfigurationWizard.log. 

 

ERROR SettingsController - Error while trying to read 'Enable Windows Login' setting. Details: System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

Environment

All Orion Core products

 

Cause 

The error is caused by a firewall to your network.

 

Resolution

Create an inbound firewall exception for the Dynamic SQL Server port used by the named SQL instance your are using for your Orion installation. 

 

 

Last modified
21:55, 22 Jun 2016

Tags

Classifications

Public