Submit a ticketCall us
Home > Success Center > Network Performance Monitor (NPM) > Compatibility of SolarWinds Orion products for installation and upgrade and End of Life Support

Compatibility of SolarWinds Orion products for installation and upgrade and End of Life Support

Overview

This article helps you construct an upgrade path for Orion Platform-based products, whether they are installed together or by themselves.

The SolarWinds Product Upgrade Advisor can help you upgrade your Orion products. You should use the Product Upgrade Advisor with the SolarWinds Upgrade Guide to upgrade your Orion products. These include:

  • IP Address Manager (IPAM)
  • NetFlow Traffic Analyzer (NTA)
  • Network Configuration Manager (NCM)
  • Network Performance Monitor (NPM)
  • Patch Manager
  • Server & Application Monitor (SAM)
  • Storage Resource Monitor (SRM)
  • User Device Tracker (UDT)
  • VoIP & Network Quality Manager (VNQM)
  • Web Performance Monitor (WPM)

Environment

  • All versions of Orion Platform products

Product compatibility charts

The following articles provide updated lists of compatible product versions with NPM and SAM. These charts provide Orion and non-Orion compatibility information.

Details

The information in this article is updated for the latest products and versions. You can review this information to understand the compatibility of products. We recommend, however, using the links and information in the above sections.

Installing Orion Platform products together lets them operate as a single product. This interoperability sometimes means that you have to upgrade your products in a certain sequence. Older versions of products have a varying range of compatibility with the newer versions of Orion Platform that the more recent products are based on. We use Network Performance Monitor (NPM) as the baseline for upgrade planning, and to describe the upgrade sequences for the other products in relation to it.

If you are upgrading a single product installed by itself or with SolarWinds NPM, read the section that has your product in its title. This section describes the recommended paths for upgrading a stand-alone product and for upgrading the product with SolarWinds NPM.

  1. Determine the highest version of NPM that is compatible with the current versions of all your products.
  2. Consult the NPM upgrade path to see if you can upgrade from your current version of NPM to this highest version.
  3. Upgrade to the highest version of NPM as possible.
  4. Determine the highest versions of your products that are still compatible with your current version of NPM.
  5. Upgrade to those versions.
  6. Repeat the steps until you have upgraded all products to the desired versions.

After installing each version of the product in your upgrade path, you must also run the configuration wizard before continuing to the next version.

If you have multiple Orion Platform products installed but NPM is not one of them, consult the sections for your products and follow these steps based on the compatibility charts:

  1. Select the highest version of NPM that is compatible with the current versions of all your products.
  2. Determine the highest versions of your products that are still compatible with that version of NPM.
  3. Upgrade your products until they are all at the highest versions supported by that version of NPM.
  4. Repeat the steps until you have upgraded all products to the desired versions.

If a particular version of software is not available in your Customer Portal, contact customer support.

In order to ensure that each step of any upgrade procedure provided below is completed fully, complete the Configuration Wizard each time after upgrading each SolarWinds product to its next version.


Enterprise Operations Console (EOC)

Upgrade path

You can upgrade any version of EOC directly to 1.6.3.

Compatibility of EOC with NPM

Select your version of NPM:

Compatible version(s) of EOC:

  • EOC 1.3.0
  • EOC 1.3.1
  • EOC 1.3.2
  • EOC 1.4.0
  • EOC 1.4.1
  • EOC 1.5
  • EOC 1.6.1
  • EOC 1.6.2
  • EOC 1.6.3

Failover Engine (FOE)

Compatibility of FOE with NPM

Select your version of NPM:

Compatible version(s) of FOE:

  • FOE 6.7

Virtualization Manager (VMAN)

VMAN is an appliance deployed to a VM to manage your virtual environment. You can install and upgrade VMAN in your environment, or integrate with VIM standalone or with an existing Orion Platform. For integrated VMAN, also check Virtual Infrastructure Monitor (VIM) for compatible versions to plan your upgrade path.

Upgrade path

Important VMAN 7.2 appliance: You cannot upgrade the VMAN appliance from a previous version to 7.2. You must migrate to the VMAN 7.2 appliance. Migration is supported for previous VMAN appliance versions including 6.3.2, 7.0, and 7.1.

VMAN 4.1.3 ⇒ VMAN 5.1.1 ⇒ VMAN 6.0.0 ⇒ VMAN 6.3.1 ⇒ VMAN 6.3.2 ⇒ VMAN 7.0 ⇒ VMAN 7.1 ⇒ VMAN 7.2

For direct upgrades to the latest:

  • VMAN 6.0.0 ⇒ 7.1
  • VMAN 6.0.1 ⇒ 7.1
  • VMAN 6.1.0 ⇒ 7.1
  • VMAN 6.1.1 ⇒ 7.1
  • VMAN 6.2.0 ⇒ 7.1
  • VMAN 6.3.0 ⇒ 7.1
  • VMAN 6.3.1 ⇒ 7.1
  • VMAN 6.3.2 ⇒ 7.1
  • VMAN 7.0 ⇒ 7.1

After installing each version of the product in your upgrade path, you must also run the configuration wizard before continuing to the next version.

Compatibility of VMAN with VIM

Select your version of VIM:

Compatible version(s) of VMAN:

  • VMAN 6.0.0
  • VMAN 6.0.1
  • VMAN 6.1.0
  • VMAN 6.1.1
  • VMAN 6.2.0
  • VMAN 6.3.0
  • VMAN 6.3.1
  • VMAN 6.3.2
  • VMAN 7.0.0
  • VMAN 7.1.0
  • VMAN 7.2.0

Virtual Infrastructure Monitor (VIM)

With version 7.0 and later, IVIM is now Virtual Infrastructure Monitor (VIM).

VIM comes as part of NPM. If you install VMAN with VIM standalone, you get the VIM install in the full product zip of VMAN from the Customer Portal. You need to upgrade VIM for VMAN integrated in a VIM standalone and existing Orion Platform environments. The VIM installation file may include additional features and updates.

Upgrade path with NPM

NPM 10.5 (IVIM 1.6) ⇒ IVIM 1.7 ⇒ NPM 10.6 (IVIM 1.8.1) ⇒ IVIM 1.9 ⇒ NPM 11.0 (IVIM 1.10) ⇒ IVIM 1.11 ⇒ NPM 11.5 (IVIM 2.0) ⇒ NPM 11.5.2 (IVIM 2.1) ⇒ NPM 11.5.3 (IVIM 2.1.1) ⇒ NPM 12.0 (IVIM 2.1.2) ⇒ NPM 12.0.1 (VIM 7.0) ⇒ VIM 7.1

After installing each version of the product in your upgrade path, you must also run the configuration wizard before continuing to the next version.

Compatibility of VIM with NPM

Select your version of NPM:

Compatible version(s) of VIM:

  • VIM 1.7.0
  • VIM 1.8.1
  • VIM 1.9.0
  • VIM 1.10.0
  • VIM 1.11.0
  • VIM 2.0
  • VIM 2.1
  • VIM 2.1.2
  • VIM 7.0.0
  • VIM 7.1.0

Engineer's & Standard Toolset

Compatibility

Select your version of NPM:

Compatible version(s) of Engineer's & Standard Toolset:

  • Toolset 10.6.0
  • Toolset 10.7.0
  • Toolset 10.8.0
  • Toolset 10.9.0
  • Toolset 11.0
  • Toolset 11.0.1
  • Toolset 11.0.2
  • Toolset 11.0.3

Engineer's Toolset on the Web

Compatibility

Select your version of NPM:

Compatible version(s) of Engineer's Toolset on the Web:

  • Web Toolset 11.0.1
  • Web Toolset 11.0.2
  • Web Toolset 11.0.3

 

Last modified
12:17, 1 Jun 2017

Tags

Classifications

Public