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Home > Success Center > Network Performance Monitor (NPM) > Cisco 3750X stack reports incorrect power supply status

Cisco 3750X stack reports incorrect power supply status

Updated October 3, 2017

Overview

You may find that your Cisco 3750X stacked switches report a faulty/not functioning power supply via the Hardware Health Sensors in NPM.

 

This is illustrated in the following screenshot:

Environment

  • NPM, all versions

Cause 

This is caused by the device reporting a value of 6 for the affected power supply and can be seen in the SNMP walk results from the device using the instructions below:

 

https://support.solarwinds.com/Success_Center/Network_Performance_Monitor_(NPM)/SolarWinds_SNMP_Walk_A_new_tool_for_collecting_SNMP_MIB_walks

 

Search for .1.3.6.1.4.1.9.9.13.1.5.1.3 and .1.3.6.1.4.1.9.9.13.1.5.1.4 in the results.

 

Specifically, the OID strings will appear as such (note that the UID 1058 and 1061 may differ in your environment):

 

.1.3.6.1.4.1.9.9.13.1.5.1.3.1058 = INTEGER: 6
.1.3.6.1.4.1.9.9.13.1.5.1.3.1061 = INTEGER: 1
.1.3.6.1.4.1.9.9.13.1.5.1.4.1058 = INTEGER: 2
.1.3.6.1.4.1.9.9.13.1.5.1.4.1061 = INTEGER: 2

Resolution

  1. According to the following article, this is fixed in Cisco IOS versions 15.0(2)SE3 & 12.2(55)SE8: https://supportforums.cisco.com/discussion/12135611/3750-management-server-show-rps-notexist-statenotfunctioning
  2. If this update is not available to you or if you are unable to upgrade the IOS on your Cisco 3750X, please note that there is a Feature Request to address this issue from the SolarWinds side as a work-around. However, we can't guarantee this will be fulfilled as the root cause is improper SNMP results from the Cisco 3750X.  https://thwack.solarwinds.com/ideas/2182

 

 

 

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