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Home > Success Center > Network Performance Monitor (NPM) > Cannot connect to NetPerfMon database DataSource=GSMGSQL01 ;Initial Catalog=NetPerfMon;UserID=SolarwindsNPM;

Cannot connect to NetPerfMon database DataSource=GSMGSQL01 ;Initial Catalog=NetPerfMon;UserID=SolarwindsNPM;

Created by Interspire Import, last modified by Kevin.Swinson on Nov 09, 2017

Views: 268 Votes: 1 Revisions: 10

Updated April 29th, 2016

Issue

Connection to the database fails when you are trying to access the Basic and Advanced Alert applications. The following error message appears:

Cannot connect to NetPerfMon database
DataSource=GSMGSQL01 ;Initial Catalog=NetPerfMon;UserID=SolarWindsNPM;

Environment

NPM v10.7

Cause

There are unnecessary line spaces in the SWNetPerfMon.DB file that is causing the database to fail when trying to access the Basic and Advanced Alert applications.

Resolution

Do the following steps to edit the SWNetPerfMon.DB file.

  1. Go to C:\Program Files (x86)\SolarWinds\Orion and locate the SWNetPerfMon.DB file.
  2. Search for the text DataSource=GSMGSQL01 ;Initial Catalog=NetPerfMon;UserID=SolarWindsNPM;
  3. Remove the unnecessary line spaces before and after the text DataSource=GSMGSQL01 ;Initial Catalog=NetPerfMon;UserID=SolarWindsNPM;
  4. Save the SWNetPerfMon.DB file.
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