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Home > Success Center > Network Performance Monitor (NPM) > Business Layer or Module Engine fails to start or constantly restarts after migrating the main NPM server

Business Layer or Module Engine fails to start or constantly restarts after migrating the main NPM server

Updated January 17, 2017

Overview

After migrating the main NPM server to a new server, there is an error message or event stating that the Module Engine or Business Layer failed to start. The service may also restart every couple of minutes. This can cause Information Service (SWIS) errors after clicking the web page or cause the web page to be inaccessible for several minutes. You may also get the error message below in the C:\ProgramData\Solarwinds\Logs\Orion\BusinessLayerHost.log. In the error message, you will see that the old NPM server is listed. In this case, NPM_Server instead of the new hostname of the current sever. 

 

Error:

2017-01-16 09:47:32,639 [7] ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "Core Business Layer" failed to start.
System.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]: Create failed, check fault information.
Could not connect to net.tcp://NPM_Server:17777/SolarWinds/InformationService/v3/Orion/certificate. The connection attempt lasted for a time span of 00:00:21.0595950. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a...

Environment

All NPM versions

Cause 

There are duplicate entries in the database.

Resolution

  1. Create a backup of your database and make sure you can restore it back if needed.
  2. Stop all Orion Services. Click Start > All Programs > SolarWinds Orion > Advance Features > Orion Service Manager > click Shut Everything Down.
  3. Start Database Manager. Click Start > All Programs > SolarWinds Orion > Advance Features > Database Manager.
  4. Click Add default server > expand and find your NPM Database
  5. Scroll down and double click the Engines table (for NPM 12 and later versions) or the All Engines table (for versions earlier than NPM 12.0).
  6. Click Execute query.
  7. The old NPM server should be listed with its respective Engine ID (see notes below).
  8. Click on Enable table editing.
  9. On the row with your old NPM server, right click on the very left most box with the arrow in it.
  10. Click the Delete the selected row(s) button.
  11. Restarted services.

Note: You may also need to move all your nodes to the new polling engine. If your nodes are on the old NPM server, then none of nodes will be polling statistics or current status. To find out what Engine ID your nodes are attached to, double click the NodesData table and scroll over to  EngineID.  If they are on the old EngineID, copy and paste the following query into Database Manager, and then click Execute Query.

UPDATE [dbo].[NodesData] Set EngineID = [New EngineID] WHERE EngineID = [old_EngineID]

 

Last modified
19:07, 27 Mar 2017

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