Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Network Performance Monitor (NPM) > Basic alerts failure after upgrading NPM

Basic alerts failure after upgrading NPM

Table of contents

Updated October 4th, 2017

Issue

After an NPM upgrade, basic alerts fail to trigger the email.

Cause

The registered component object model (COM)-based components may be corrupted.

Resolution

Re-register the COM components to re-enable the basic alert actions:

  1. Stop the Orion Services - How to Start/Stop Orion Services.
  2. Click Start > Run > Type CMD, to open command prompt.
  3. Change directory to C:\Program Files (x86)\SolarWinds\Orion, and then type the command:

    OrionAlertEngine.exe /regserver
  4. Change directory to C:\Program Files (x86)\SolarWinds\Common, and then type the command:

    regsvr32 SWAlertActions.dll
  5. Start the Orion Services - How to Start / Stop Orion Core Services
  6. To verify that basic alerts is working, run the OrionAlertEngine.exe file. This file is located in the Orion folder.

 

Applies to: NPM 11.0.1 and older.

Does not apply to: NPM 12.2 or newer, seems that OrionAlertEngine.exe is not in that file path so it must have been moved or pushed out in later releases.

Last modified

Tags

Classifications

Public