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Home > Success Center > Network Performance Monitor (NPM) > All objects on the maps are greyed out in the NPM Web Console

All objects on the maps are greyed out in the NPM Web Console

Created by Maciej Klasa, last modified by Gary O'Donovan on Jan 13, 2017

Views: 93 Votes: 4 Revisions: 23

Overview

All objects on the maps are displayed as greyed out icons in the NPM Web Console while they appear as normal in Network Atlas.

Environment

  • All NPM versions
  • All Network Atlas versions located on the server side.

Cause 

This issue is caused by a bad installation of Network Atlas or permissions.

Resolution

Workaround

  1. Go to <Volume>:\Program Files (x86)\SolarWinds\Network Atlas\Maps and copy the following folders:
    LEDS
    MapStyles
    NetObjects
    Overlays
  2. Go to <Volume>:\Program Files (x86)\SolarWinds\Network Atlas\MapsWeb and paste the copied folders.

 

 

 

If the above steps do not work, make sure that Network Atlas has been installed properly:

  1. Create a single desktop folder named Network_Atlas_Backup.
  2. Backup the following folders:
    LEDS
    ​MapStyles
    NetObjects
    Overlays
    from <Volume>:\Program Files (x86)\SolarWinds\Network Atlas\Maps to Network_Atlas_Backup\Maps\.
  3. Create subfolders under Network_Atlas_Backup called TEMP and Solarwinds onto the Network_Atlas_Backup folder: Desktop\Network_Atlas_Backup\TEMP\ folder at the following locations:
    <Volume>:\\Windows\Temp\Solarwinds\NetworkAtlas\ (copy into the desktop\Network_Atlas_Backup\TEMP folder)
    <Volume>:\Program Files (x86)\SolarWinds\Network Atlas\ or
    (Depending on where it was installed)  <Volume>:\Program Files (x86)\SolarWinds\Orion\Network Atlas\ and
    <Volume>:\Program Data\Solarwinds\NetworkAtlas\ (copy into the desktop\Network_Atlas_Backup\Solarwinds\ folder)
  4. Once you have finished a backup of current data, delete the original folders under the following locations:
    <Volume>:\Program Files (x86)\SolarWinds\Network Atlas\
    <Volume>:\Program Data\SolarWinds\Network Atlas\ 
    <Volume>:\\Windows\Temp\Solarwinds\Network Atlas\                   
  5. Create a local server administrator account.
    Note: This can be disabled or even deleted after the installation but will help ensure that there will be no permissions issue after these steps..
  6. Login to the Orion server using the created local server administrator account.
  7. Disable the AntiVirus program before the installation.
    Note: You can enable the AV program once the installation is complete.
  8. Go to <Volume>:\Program Data\ Solarwinds\installers,  and double click SolarWinds-Orion-NetworkAtlas.msi to install Network Atlas.
  9. Make sure the the installation path matches the current \Orion installation directory -                                                          <Volume>:\Program Files (x86)\SolarWinds\Orion\Network Atlas\.

 

Note: This can be also fixed with permissions checker upon repair of NA, missing permission in mapweb. Verify that your path to the folders follow the path as listed below and that they should contain the same data:

 

  • C:\Program Files (x86)\SolarWinds\Orion\Network Atlas\Maps
  • C:\Program Files (x86)\SolarWinds\Orion\Network Atlas\MapsWeb

 

Last modified
09:16, 13 Jan 2017

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