Submit a ticketCall us

Solarwinds & Cisco Live! Barcelona
Join us from the 29th of January to the 2nd of February at Cisco Live 2018 in Barcelona, where we will continue to show how monitoring the network with SolarWinds will keep you ahead of the game. At our booth (WEP 1A), we will demonstrate how SolarWinds network solutions can help. As a bonus, we are also hosting a pre-event webinar - Blame the Network, Hybrid IT Edition with our SolarWinds Head Geek™, Patrick Hubbard on January 24th - GMT (UTC+0): 10:00 a.m. to 11:00 a.m. There's still time to RSVP.

Home > Success Center > Network Performance Monitor (NPM) > All NetPath Services showing as Down

All NetPath Services showing as Down

Updated August 5, 2016

Overview

Checking the NetPath Services from the Orion Web Console, all paths are showing as Down even when they are supposed to be Up.

Environment

NPM 12.0

Cause 

This usually happens when the Database Maintenance did not run for more than 7 days.

The following appears when checking the C:\ProgramData\Solarwinds\Logs\Orion\swdebugMaintenance.log.

 

From Collector.Service.log, you will notice that there are missing new partitioned tables (used for storing NetPath results).

2016-07-11 08:04:26,161 [5] ERROR SolarWinds.NetPath.Data.Storage.SqlDataWriter - Got an error while writing the following traces 2, 2, 7/11/2016 2:01:24 PM(636038424849101828)
System.Data.SqlClient.SqlException (0x80131904): The attempted insert or update of the partitioned view failed because the value of the partitioning column does not belong to any of the partitions.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
---
2016-07-11 08:04:26,171 [5] ERROR SolarWinds.NetPath.Collector.DAL.TracerouteResultDAL - Store traceroutePollerResult failed.
System.Data.SqlClient.SqlException (0x80131904): The attempted insert or update of the partitioned view failed because the value of the partitioning column does not belong to any of the partitions.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)

Resolution

  1. Manually run Database Maintenance and wait until it finishes.
    a. From the Orion server, go to Start Menu > Programs > SolarWinds Orion > Advanced Features > Database   Maintenance.
    b. Click Start.
    c. Click Close once you see 'Status: Database Maintenance Complete.'
  2. NetPath should be able to store its processed data and will resolve the issue.

 

Last modified

Tags

Classifications

Public