Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

 

 

 

Home > Success Center > Network Performance Monitor (NPM) > Alerts not working after NPM 12.0 RC upgrade

Alerts not working after NPM 12.0 RC upgrade

Updated September 7th, 2016

Overview

 

This has been resolved in DPA 10.1 SR1 which is now available in customer portals.

Steps to resolve:

  1. On Orion side, Settings -> Database Performance Analyzer Settings -> Set up DPA Integration -> Remove Integration
  2. Upgrade DPA to 10.1 SR1 from portal
  3. Re-integrate Orion and DPA

 

Customers are unable to receive any email notifications after updating NPM to a version 12.0 RC 1, 2, or 3.

Customers will get the following error when testing alerts NetObjectData is null

 Sample errors can be seen on the AlertingV2 and SWIS v3 logs:

2016-06-02 15:36:53,270 [42] ERROR SolarWinds.InformationService.Core.InformationService - (null)     Exception caught in method SolarWinds.InformationService.Core.InformationService.Delete
System.ServiceModel.FaultException: com.solarwinds.data.ArgumentException: No such entity instance.

Server stack trace: 
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at SolarWinds.InformationService.Contract2.IInformationService.Delete(String uri)
   at SolarWinds.InformationService.Contract2.InfoServiceProxy.Delete(String uri)
   at SolarWinds.Data.Providers.DPA.V3.Federation.FederationSwisProxy.<>c__DisplayClass8_0.<ExecuteActionWithImpersonation>b__0(InfoServiceProxy proxy)
   at SolarWinds.Data.Providers.DPA.V3.Federation.FederationSwisProxy.ExecuteActionWithImpersonation[T](Func`2 function)
   at SolarWinds.InformationService.Core.CrudProcessor.Delete(SwisUri uri, IQueryExecutionContext context)
   at SolarWinds.InformationService.Core.InformationService.Delete(String uri)

Environment

  • NPM 12.0 RC1
  • NPM 12.0 RC2
  • NPM 12.0 RC3
  • DPA 10 

Cause 

Problem was caused by a issue with DPA integration and SWIS Federation. This occurs if customer has DPA installed on same host as Orion. Removing DPA integration resolves the issue. 

Resolution

  1. Stop all Orion services.
  2. Go to Start > Control Panel > Uninstall a program > "SolarWinds Orion-DPA Integration" > UNINSTALL.
  3. Complete Configuration Wizard.
  4. Stop SolarWinds Information Service v3 using Orion Service Manager.
  5.  Run the following query against customer's Orion database:

DELETE FROM FED_ProviderSubscriptions
DELETE FROM FED_Subscription
DELETE FROM FED_RemoteInformationServices

  1. Restart SolarWinds Information Service v3 using Orion Service Manager.

 

Last modified
15:47, 12 Jan 2017

Tags

Classifications

Public