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Home > Success Center > Network Performance Monitor (NPM) > Alerts actions no longer sending SMS using 3rd party log to a file action

Alerts actions no longer sending SMS using 3rd party log to a file action

Overview

Alerts are not firing/triggering with the following symptoms or issues:

  • SMS and Email alerts are defined and they used to work as intended. But now they do not fire or trigger and nothing has been changed in the settings.
  • CPU alerts are still being received. But when a node/group is down, no alerts are received.
  • On the Active alerts window, alerts are not visible and only shows the An error has occurred message.
  • Alerts were working in NPM 11.5.2 and something stopped this from working in NPM 12.

Environment

NPM v12.0 or later

Cause 

This is a known issue in NPM v12. 

In 11.5 the file generated was in UTF-8. In NPM 12,  it is saving the file in "UTF-8-BOM"

The result of this is that your Text file > SMS is no longer working after the upgrade.

Resolution

We recommend investigating if the 3rd party tool can be updated, we are using standard format for our log file.
As temporary workaround, you can convert encoding for those files using Notepad++.

 

Last modified
22:40, 30 Aug 2016

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