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Home > Success Center > Network Performance Monitor (NPM) > Alert variable is not showing data

Alert variable is not showing data

Updated September 21, 2016

Overview

The email title or body only displays variables instead of correct data when creating an alert. For example:

ALERT: [${N=SwisEntity;M=CustomProperties.Brand} ${N=SwisEntity;M=CustomProperties.Region} ${N=SwisEntity;M=CustomProperties.Site_Code} Up ] - Node 1 is Up

Environment

NPM 12+ and earlier

Cause 

Upon checking the Orion web log, the following error occurs:

 

2016-09-20 10:24:02,176 [33] ERROR SolarWinds.InformationService.Contract2.InfoServiceProxy - Error closing exception.
System.ServiceModel.CommunicationObjectFaultedException: The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.

Server stack trace: 
   at System.ServiceModel.Channels.CommunicationObject.Close(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Close()

Resolution

 

  1. Click Start and enter ORION SERVICE MANAGER.
  2. Click Shutdown Everything to stop all SolarWinds services.
  3. Go to Documents and Settings\All Users\Application Data\SolarWinds\Installers
    Note: For Windows 2008 or later, the path is C:\ProgramData\Solarwinds\installers
  4. Run Informationservice.msi and uninstall it.
  5. After uninstalling, go back to Orion Service Manager and verift that all SW services are still stopped. Leave Orion Service Manager open and launched.
  6. Run the following query on the Orion SQL Database:
    DELETE FROM ContainerMemberSnapshots
  7. Return to Documents and Settings\All Users\Application Data\SolarWinds\Installers
    Note: For Windows 2008 or later, the path is C:\ProgramData\Solarwinds\installers
  8. Run InformationService.msi and install it. 
  9. Start all the Orion services using the Orion Service Manager. 
 

 

Last modified
10:08, 19 Apr 2017

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