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Home > Success Center > Network Performance Monitor (NPM) > Agents can't connect to Agent Management Service

Agents can't connect to Agent Management Service

Created by Chris Foley, last modified by MindTouch on Jun 23, 2016

Views: 52 Votes: 0 Revisions: 4

Overview

A few different symptons:

  • IIS's httperr file is filling up the drive with the following errors: /solarwinds/agentmanagement/solarwinds/messaging/signalr/negotiate?clientProtocol=1.3 404 - NotFound.
  • BusinessLayerHost.log file contains the following error when starting the DPI Business Layer plugin:
    ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "DPI Business Layer" failed to start. System.Runtime.Serialization.SerializationException: Unable to find assembly 'SolarWinds.DPI.BusinessLayer, Version=2.0.6.593, Culture=neutral, PublicKeyToken=null'.
  • AgentManagent.Service.log and AgentManagement.AMSProxy.log files are not getting updated.

Environment

  • Any Orion Module that includes QoE (DPI) module
  • Following applications are installed:
    • Visual C++ 2012 Redistributable (x86)
    • Visual C++ 2012 Redistributable (x64)
    • Visual C++ 2013 Redistributable (x86)
    • Visual C++ 2013 Redistributable (x64)

Cause 

The Agent Management Service plugin has been disabled for some reason.

Resolution

  1. Run Notepad as Administrator.
  2. Open the following file:
    \solarwinds\orion\agentmanagement\Solarwinds.AgentManagement.ServiceCore.dll.config
  3. Find the following line:
    <Solarwinds.busnessLayerHost LoadPlugins="false"
  4. Change it to the following:
    <Solarwinds.busnessLayerHost LoadPlugins="true"
  5. Stop and start the Orion Module Engine service.

 

Last modified
21:41, 22 Jun 2016

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